koshka99
10.04.2022 17:12

1)Написать программу, в которой массив из 12 элементов заполняется случайными целыми числами в интервале [10,30] и выводится на экран. Найдите максимум среди элементов, стоящих на четных местах.2)Представьте себе ,что две команды набрали по 59 очков.Например,ЦСКА и ЗЕНИТ.Номер какой команды был бы выведен в качестве результата?3)При условии из предыдущего задания определите,какие будут выведены результаты,если в операторе ветвления ,где отбирается максимальное значение,заменить знак отношения ">" на ЗАРАНЕЕ класс

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
marina19793
20.10.2021 16:00
Const
  n = 15;

var
  x: array[1..n] of integer;
  i, k, t, min: integer;

begin
  Randomize;
  Writeln('Исходные элементы массива');
  min := 1000;
  for i := 1 to n do
  begin
    x[i] := Random(101) - 50;
    Write(x[i]:4);
    if min > x[i] then begin
      min := x[i];
      k := i
    end
  end;
  t := x[k]; x[k] := x[1]; x[1] := t;
  Writeln;
  Writeln('Результирующие элементы массива');
  for i := 1 to n do Write(x[i]:4);
  Writeln
end.

Исходные элементы массива
 -28 -22 -15   3  27  29  34 -29 -49 -37 -19  31  40 -36   4
Результирующие элементы массива
 -49 -22 -15   3  27  29  34 -29 -28 -37 -19  31  40 -36   4
0,0(0 оценок)
Ответ:
Samsas
20.10.2021 14:36
Мы живем в двадцать первом веке. Это век передовых технологий и научно-технического прогресса. Смело можно сказать, что сейчас у большинства молодежи имеются компьютеры и различная современная техника. Многие задаются вопросом : служит ли компьютер или наоборот влияет негативно на нашу жизнь?
Я определенно могу ответь, что для меня, компьютер является Во-первых, там я могу достать всю необходимую информацию не выходя из дома. 
Во-вторых, постоянно узнаю новые события о своей стране, о зарубежных государствах да в различных сферах деятельности.
В третьих, компьютер служит отличным развлекательным гаджетом отвлечься от бытовых проблем.
Я хочу сказать, что компьютер на самом деле - вещь необходимая и нужная.
Главное, уметь им пользоваться. Только от вас зависит, будет вредить он вам или
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота