даданет
12.11.2020 00:30

1. Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.
текст программы
var m: array [1..6] of integer;
i: integer;
begin
writeln('ввод элементов');
for i:=1 to 6 do readln(m[i]);
for i:=1 to 6 do write(m[i],' ');
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
borisrrvdow9kk7
19.01.2020 07:55
Начало:1.подойти к телефону,2.поднять трубку телефона,3.набрать номер друга,4.подождать пока друг поднимет трубку,5.поговорить с другом,6.поставить трубку на место,7.отойти от телефона. конец                                                                                                                                                                                                                             это линейный алгоритм.в линейном алгоритме шаги выполняются в той последовательности,в которой они записаны
0,0(0 оценок)
Ответ:
sileeet
17.06.2022 18:13
Using System;

static void Main()
{
        int[] sourceArray = new int[] {3, 1, -4, -4, 65};                  //Исходный массив
        int[] newArray = new int[sourceArray.Length * 2];                  //Новый массив с максимальной нужной длиной
        int newArrayIndex = 0;                                             //Индекс для нового массива
        for (int i = 0; i < sourceArray.Length; i++)
        {
                newArray[newArrayIndex++] = sourceArray[i];
                if (i == sourceArray.Length - 1 || sourceArray[i] != sourceArray[i + 1])
                        newArray[newArrayIndex++] = 0;
        }
        for (int i = 0; i < newArrayIndex; i++)                            //Выводим новый массив на экран
                Console.Write(newArray[i] + " ");
        Console.ReadKey();
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота