4553234
07.10.2022 17:06

Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три цифры номер выход: первая строка представляет собой сумму цифр(в python)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tomatik47
18.08.2020 09:59

n=int(input("Число: "))

sum = 0

while n>0:

   sum += n%10

   n=int(n/10)

   

print(sum)

Объяснение:


Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три ци
0,0(0 оценок)
Ответ:
SerenaWilliamsisa
18.08.2020 09:59

python не знаю, но подскажу.

Объяснение:

тебе нужно найти остаток от деления на 10, потом остаток прибавить к сумме. После, входное число нацело разделить на 10. Оставшейся число пропускаем через эти шаги до того момента, пока оно не будет равняться 0

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота