Hhhhhhhhelppppp
06.08.2021 22:32

Программы написать на питоне
1. На вход программе подается натуральное число. Найдите количество цифр не больше 6 в числе.
2. На вход программе подается 2 натуральных числа. Определите у какого числа сумма цифр больше. В ответе выведите 1, если сумма цифр 1 числа больше, 2, если второго, 0 если сума цифр одинаковая
3. На вход программе подается натуральное число. Найдите самую маленькую цифру числа. При решении этой задачи повторите тему поиска минимума.
4. На вход программе подается натуральное число. Напишите программу, которая выводит первую цифру числа.
5. На вход программе поступает последовательность целых чисел по одному числу в каждой строке, все числа последовательности отличны от нуля. Количество чисел неизвестно. Ввод данных заканчивается вводом числа 0. После этого водятся числа x и y.
Найдите количество чисел, попадающих в отрезок [x, y]

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
soykaksyu
21.12.2022 08:02
Человек лучше понимает и запоминает ту информацию, которая представлена наглядно — с рисунков, фотографий, схем, диаграмм.И дети, и взрослые любят иллюстрированные книги, потому что рисунки позволяют очень быстро понять, о чём идет речь. Так, чтобы понять, о чем написано в выделенном ниже фрагменте текста, вам потребуется приблизительно полминуты; чтобы воспринять смысл рисунка, будет достаточно нескольких секунд. Проверьте.В современных супермаркетах каждый товар имеет на упаковке штрих код — метку, состоящую из чёрных линии. Для чтения штрих-кодов применяют специальные штрих-сканеры. С их в компьютер вводят данные о стоимости покупки.


Для того чтобы показать, как устроены окружающие нас объекты (предметы, процессы, явления) и как они связаны друг с другом, используют схемы.Каждый ученик 5 класса знает схематичное изображение приставки, корня, суффикса и окончания слова. Поэтому вы сразу поймёте, о чём идёт речь, если учитель русского языка попросит подобрать слова, соответствующие следующей схеме:Для наглядного представления разных числовых данных используют диаграммы.
0,0(0 оценок)
Ответ:
LenysikRESHAETVSE
21.12.2022 08:02
Program kvur;
var
x1,x2,d,e,f, a, b, c: real;
begin
writeln('Решение квадратного уравнения(ax^2+bx+c=0).');
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
d:=sqr(b)-4*a*c;
writeln('вы ввели:');
writeln('a= ',a:6:2);
writeln('b= ',b:6:2);
writeln('c= ',c:6:2);
writeln('D=b*b-4*a*c=',d:6:2);
if (d>=0)
then begin
e:= (-b/(2*a));
f:= (sqrt(d)/(2*a));
x1:= (e+f);
x2:= (e-f);
writeln('D>= 0, значит корни действительные: ');
writeln('x1= ',x1:6:2);
writeln('x2= ',x2:6:2);
end;
if(d<0) then begin
e:= (-b/(2*a));
f:= (sqrt(-d)/(2*a));
x1:= (e+f);
x2:= (e-f);
writeln(' D<0, значит корни комплексные: ');
writeln('x1= ', e:6:2, ' + ', f:6:2, 'i');
writeln('x2= ', e:6:2, ' - ', f:6:2, 'i');
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота