evamakuh
11.03.2022 04:35

Составьте программу для решения задачи (определение дня недели)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yanaantonova0
20.03.2021 20:54
Может быть, так:
uses graphABC;
Begin
setfontcolor(clRed);
writeln('Белеет парус одинокой');
setfontcolor(clBlue);
writeln('В тумане моря голубом!..');
setfontcolor(clDarkOrchid);
writeln('Что ищет он в стране далекой?');
setfontcolor(clDeepSkyBlue);
writeln('Что кинул он в краю родном?..');
setfontcolor(clDeepPink);
writeln('Играют волны - ветер свищет,');
setfontcolor(clMagenta);
writeln('И мачта гнётся и скрыпит...');
setfontcolor(clDarkGreen);
writeln('Увы! он счастия не ищет');
setfontcolor(clLime);
writeln('И не от счастия бежит!');
setfontcolor(clBrown);
writeln('Под ним струя светлей лазури,');
setfontcolor(clIndigo);
writeln('Над ним луч солнца золотой...')
End.
0,0(0 оценок)
Ответ:
nairisaaryan
05.02.2022 19:29
20 страниц, в каждой 5 строк по 20 символов. Всего символов  в книге: 2000.
Переведем вес всей книги в байты: 5.86*1024=6000.64байт. А затем в биты: 6000.64*8=48005,12бит в книге.  Следовательно, один символ занимает 48000.12/2000=24.00256 бита. Но так как биты дробными не бывают, получается, что на один символ тратится 25 бит. Теперь узнаем, сколько символов может быть в алфавите, если на кодировку одного символа уходит 25 бит. Это считается по формуле N=2^i N=2^25=33554432 символов, что похоже на маразм. Видимо условие не совсем точно)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота