ИЗЫДИ666
01.05.2020 17:15

Сортировка выбором. Дан массив A[N]. Требуется переставить элементы так, чтобы они были расположены по убыванию. Для этого в массиве, начиная с первого, выбирается наибольший элемент и ставится на первое место, а первый – на место наибольшего. Затем, начиная со второго, эта процедура повторяется. Написать программу сортировки выбором и протестировать её на трёх различных тестах. Язык программирования - Pascal ABC.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
annnnka16
08.03.2022 04:51
Возможность создавать новый документ, используя при этом шаблоны.Возможность одновременно открывать и работать не с одним числом документов.Автоматически проверять орфографию, стилистику и грамматику при вводе текста в документ.Возможность автоматические корректировать ошибки, которые больше всего повторяются в написанном.Включает в себя расширенные возможности по форматированию документа.Возможность применять стили для быстрого форматирования документа.Включает в себя удобные механизмы по работе со сносками, ссылками, колонтитулами.Позволяет включать в текст элементы, которые были созданы в других программах, входящих в Microsoft Office: электронные таблицы, графические изображения или фотографии, графику, видеоизображения, звуки и многое другое.Возможность подготавливать гипертекстовые документы Internet и простые электронные таблицы.Возможность автоматические создавать указатели и оглавление документа.Возможность для отправки готового документа сразу из Word'a по электронной почте или же другому человеку или предприятию на факс.Содержит встроенную объемную систему и мастер подсказок.
0,0(0 оценок)
Ответ:
marinakrivoshe
30.12.2020 04:06
Const
  n = 15;

var
  a: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(61) - 30;
    Write(a[i]:4);
    if a[i]>0 then a[i]:=2*a[i]
    else
      if a[i]<0 then a[i]:=7
  end;
  Writeln;
  Writeln('После преобразования');
  for i := 1 to n do Write(a[i]:4);
  Writeln
end.

Тестовое решение:
Элементы массива
 -20  15  16  20   0  16 -15  -1  -2  21  -8 -10   4 -24   1
После преобразования
   7  30  32  40   0  32   7   7   7  42   7   7   8   7   2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота