karinaeruslanov
21.01.2023 05:37

Написать программу перевода из 16 и 8 -ричнных систем счисления в ДВОИЧНУЮ и обратно.(паскаль С ИНФОРМАТИКОЙ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
мопс22
06.08.2021 06:18

Объяснение:

Начало;

Ввод X, Y (они у нас уже есть в табл. 1 и 2 (к примеру, в 1 табл. X=9, Y=14));

X=Y (у нас X=9, Y=14; 9 не равна 14, а это значит мы идём по стрелочке "нет");

X>Y (9 не больше 14, идём по стрелочке "нет");

Y=Y-X (подставляем в формулу наши X, Y из табл. 1 и получаем Y=14-9=5);

Теперь переходим на новую строчку табл. 1. X остаётся прежним (9), а в Y пишем тот, что мы нашли (5). Начинаем всё заново.

X=Y (9 не равна 5, идём по стрелочке "нет");

X>Y (9 больше 5, а это значит мы идём по стрелочке "да");

X=X-Y (подставляем в формулу наши X, Y. Это уже будет X=9-5=4)

Теперь переходим на новую строчку табл. 1. X теперь 4, а Y остаётся  прежним (5). Начинаем всё заново.

Так проделываем каждый раз пока X не станет равно Y (в 1 табл. это 1=1).


Информатика алгоритмы.
0,0(0 оценок)
Ответ:
AmyDay123
04.10.2022 12:14

1) program kolvo;

var k, maks, i:integer;

a:array[1..10] of integer;

begin

k:=0;

maks:=0;

for i:=1 to 10 do

begin

writeln('Введите чичло номер ', i);

readln(a[i]);

if a[i]>maks then maks:= a[i];

end;

for i:=1 to 10 do

begin

write(a[i], ' ');

if a[i]<maks div 2 then k:=k+1;

end;

writeln;

writeln('Количество чисел, что минимум в два раза меньше максимального числа в массиве ', k);

end.

2)program maks;

var k, maks, i:integer;

d:array[1..5] of integer;

begin

k:=0;

maks:=0;

for i:=1 to 5 do

begin

writeln('Введите чичло номер ', i);

readln(d[i]);

if d[i]>maks then begin maks:= d[i]; k:=i; end;

end;

writeln;

for i:=1 to 5 do write(d[i], ' ');

writeln;

writeln('Номер максималтного числа в массиве ', k);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота