Dima1Tap
18.07.2020 01:09

Напишите программу на языке паскаль для решения следующей задачи дан квадрат со стороной а прямоугольный треугольник со стороны б чья площадь меньше​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Катя111111177796
24.09.2021 14:56

stdout:

/temp/compiling/source.bas(1) error 3: Expected End-of-Line, found 'Pascal'

Pascal;

^

/temp/compiling/source.bas(2) error 10: Expected '=', found ';'

Var;

  ^

/temp/compiling/source.bas(3) error 3: Expected End-of-Line, found '�'

   a,b:integer;

^

/temp/compiling/source.bas(4) error 10: Expected '=', found ';'

Begin;

    ^

/temp/compiling/source.bas(5) error 3: Expected End-of-Line, found '�'

   read(a,b);

^

/temp/compiling/source.bas(6) error 3: Expected End-of-Line, found '�'

   write(a+b);

^

/temp/compiling/source.bas(7) error 10: Expected '='

End.

^

/temp/compiling/source.bas(9) error 3: Expected End-of-Line, found '�'

Язык C++

^

/temp/compiling/source.bas(11) error 145: Only valid in -lang fb or deprecated or fblite, found 'using'

using namespace std;

^

/temp/compiling/source.bas(12) error 6: Expected '(', found 'main'

int main() {

   ^

/temp/compiling/source.bas(12) error 132: Too many errors, exiting

stderr:

0,0(0 оценок)
Ответ:
julylana
09.05.2023 22:33

Информатика- наука, изучающая информационные аспекты системных процессов и системные аспекты информационных процессов. Это определение можно считать системным определением информатики. Информатика- это наука об инвариантах (т.е. неизменных сущностях) информационных процессов, о их выявлении, описании, изучении, применении, пространственно-временной организации и самоорганизации. Такое определение естественно назвать синергетическим определением информатики и оно имеет важное значение при исследовании синергетики информационных процессов в различных системах. Информатика тесно связана и с философией. Философия дает общие методы содержательного анализа, а информатика даёт общие методы формального анализа предметных областей (особенно, теоретическая, математическая информатика). Можно дать философское.

Можно дать философское определение информатики: информатика это наука, изучающая общие свойства и процессы отражения материи, порядок в материи, ее структурированность и отражение в сознании человека, общества. Дадим математическое определение инфор математической информатики): информатика- наука, изучающая гики (определение вопросы построения и исследования математических методов и моделей, алгоритмов, формальных систем для описания и актуализации различных информационных систем и процессов, различных классов операционных пространств. Эта — наука, математически (формальным языком) описывающая и исследующая инварианты, абстрагируясь этом от материальной основы информационных процессов. Фундаментальность информатике придаёт только широкое и глубокое использование математики, формальных методов и средств, а общность и фундаментальность её результатов, их универсальная.

Фундаментальность информатике придаёт не только широкое и глубокое использование математики, формальных методов и средств, а общность и фундаментальность её результатов, их универсальная методологическая направленность в производстве знаний. В этом смысле математическая информатика аналогична математической физике, математической биологии, математической экономике и др. Предмет информатики точно ("математически") невозможно определить, в силу его сложности, многосторонности, динамической изменчивости. Тем не менее, можно отметить следующие три основные ветви информатики (в классическом понимании), определяемые её познавательной и прагматической функциями, её внутренней и внешней сущностями (заметим, что деление информатики как науки и человеческой деятельности на те или иные части зависит от целей, задач, ресурсов).

Теоретическая, математическая информатика (brainware) изучает теоретические проблемы информатики (большей частью связанные с формальными системами, моделями, алгоритмами и теорией программирования, кодирования организации систем). Практическая, прикладная информатика (software) изучает практические, конкретные проблемы информатики (большей частью связанные с программированием и использованием моделей, программными и компьютерными технологиями и системами). Техническая, инженерно-физическая информатика (hardware) изучает инженерно-физические, технические проблемы информатики (большей частью связанные с разработкой и использованием технических средств обработки информации, ЭВМ и систем эвм, сетей). Информатика базируется на следующих основных и важных понятиях:

информация и сообщение, в частности, получение, переработка, сжатие, актуализация информации сообщениями различного типа; алгоритм и алгоритмизация, в частности, программа и программный комплекс, проектирование программ и программирование; система и структура, отношение и связь, порядок, выбор, в частности, информационные система и структура, Отношения в них; модель и моделирование, в частности, описание и исследование систем с моделей и моделирования; исполнитель и его операционная среда, в частности, ЭВМ и система языки и грамматики, в частности, алгоритмические языки, языки программирования, языки общения с различными системами и средами; проектирование систем и технология, частности, информационная, компьютерная технология.

Предметная область науки "информатика" - информационные процессы и системы, модели, языки их описания, технологии их актуализации, направленные как на получение знаний (это- внутренняя сущность информатики), так и на применение знаний, принятие на их основе решений в различных предметных областях (это- внешняя сущность информатики). Эти информационные процессы могут происходить в живых существах (организмах), автоматах (технических устройствах), обществе, в индивидуальном общественном сознании.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота