denic311
17.11.2020 06:15

Информатика

Написать программу "Дано целое число х. Вывести сообщение четное ли это число или нет. Если четно найти квадрат этого числа ПО БРАТСКИ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
морпехРФ
26.09.2022 22:33

#include <iostream>

#include <vector>

using namespace std;

int main()

{

  int x, y;

  cin >> x >> y;

  vector<vector<int> > t(x, vector<int> (y));

  for (int i = 0; i < x; ++i){

      for (int j = 0; j < y; ++j){

           int mark;

           cin >> mark;

           t[i][j] = mark;

      }

  }

  for (int i = 1; i < y; ++i){

       t[0][i] += t[0][i - 1];

  }

  for (int i = 1; i < x; ++i){

       t[i][0] += t[i - 1][0];

  }

  for (int i = 1; i < x; ++i){

      for (int j = 1; j < y; ++j){

           t[i][j] += min(t[i - 1][j], t[i][j - 1]);

      }

  }

  cout << t[x - 1][y - 1] << endl;

}

Объяснение:

0,0(0 оценок)
Ответ:
habman
31.01.2022 20:06
Операции форматирования включают в себя разбивку текста на строки (в рамках абзаца) и страницы, выбор расположения абзацев, отступов и отбивок между абзацами, обтекания отдельных абзацев, а также видов и начертаний шрифтов. Эти операции выполняются различными текстовыми процессорами с разной степенью автоматизации. Суть форматирования заключается в текстового процессора изменять оформление документа на странице, а именно:
— изменять границы рабочего поля, определяя поля сверху, снизу, слева, справа;
— устанавливать межстрочный интервал (разреженность строк на странице) и межбуквенный интервал в слове;
— выравнивать текст — центрировать, прижимать к левой или правой границе;
— равномерно распределять слова в строке;
— использовать разные шрифты и т. п.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота