vladwf111
22.09.2022 03:43

1. Опишите модель решения поставленной задачи.
а) Входные данные программы
Б) Выходные данные программы
c) Цель проектирования программы
d) Назначение программы
е) Область применения программы​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Aislu111
06.03.2021 11:15
Var 
a: array[1..100] of integer; 
i, j, c: integer;
begin 
Writeln('Массив '); 
for i := 1 to 100 do  begin   
a[i] := random(201) - 100;   
write(a[i], ' '); 
end; 
Writeln; 
write('Введите число (от -100 до 100) '); 
Readln(j); 
for i := 1 to 100 do    
if a[i] = j then begin c := c + 1; write(i, ' '); end; 
Writeln;   
if c>1 then write('В массиве число введённое вами есть в массиве и даже несколько (', c, '). Их индексы представлены выше') else  if c = 1 then write('Число, которое вы ввели есть в массиве. Его индекс представлен выше') else write('Такого числа в массиве нет');  
end.
0,0(0 оценок)
Ответ:
jutyra
30.01.2021 09:39

{Напишите программу, которая находит минимальное и максимальное

среди чётных положительных чисел, записанных в файле,

и выводит результат в другой файл.}

var f:text;

 min, max,a :integer;

 find:boolean;{есть/нет числа удовлетворяющие условию}

begin

 assign(f,'dan.txt'); reset(f);

 min:=0; max:=0;

 find:=false;

 while not eof(f) do

 begin

 read(f,a);

 if not find and (a>0) and (a mod 2=0) then

 begin

  min:=a; find:=true;

 end

 else

 if find and (a>0) and (a mod 2=0) and (min>a) then

  min:=a;

 if (a>0) and (a mod 2=0) and (max<a) then

  max:=a;

 end;

 close(f);

 assign(f,'res.txt');

 rewrite(f);

 if max=0 then writeln(f,'чётных положительных чисел нет')

 else

  writeln(f,'min среди чётных положительных чисел =',min, chr(13),

     'max среди чётных положительных чисел нет',max);

 close(f);

end.

Подробнее - на -

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота