VikaS11111
12.07.2022 18:24

Решить по информатике! 25 составить программу,которая определяет сколько слагаемых должно быть в сумме последовательности 2+4+6+8+.. и эта сумма оказалась больше заданного числа n. n> =0паскаль,8 класс!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nelia88
07.06.2020 19:16

var

 i, c, s, n:integer;

Begin

 write('Введите n: ');

 readln(n);

 s:= 0;

 c:= 0;

 write('Последовательность: ');

 while i < n do begin

   s:= s + i;

   c:= c + 1;

   i:= i + 2;

   write(i, ' ');

 end;

 writeln;

 writeln('Сумма последовательности: ', s);

 writeln('Количество слагаемых: ', c);

END.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота