Легендабокса
30.07.2020 21:00

Составьте программу, которая определяет, какое из трех чисел наибольшее. Числа вводятся с клавиатуры

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
мишаиванво
18.04.2022 10:55
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(20,-99,99); a.Println;
  var (imin,imax):=(a.IndexMin,a.IndexMax);
  Writeln('Минимальный элемент ',a[imin],', максимальный ',a[imax]);
  Swap(a[imin],a[imax]); a.Println; // меняем местами max и min
  Swap(a[0],a[a.Length-1]); a.Println // меняем местами крайние
end.

Пример
-45 78 -68 -89 -95 39 55 54 46 69 4 -36 -81 61 47 -76 0 -35 65 -47
Минимальный элемент -95, максимальный 78
-45 -95 -68 -89 78 39 55 54 46 69 4 -36 -81 61 47 -76 0 -35 65 -47
-47 -95 -68 -89 78 39 55 54 46 69 4 -36 -81 61 47 -76 0 -35 65 -45
0,0(0 оценок)
Ответ:
софия20042009
27.06.2021 02:31

Интернет символ «@» появился несколько сотен лет назад в средневековых монастырях. Его использовали для обозначения латинского предлога «ad» (в современном английском — «at»), хотя некоторые исследователи утверждают, что «собаку» придумали итальянские монахи.

Как бы то ни было, это новшество вскоре переняли торговцы: одним из первых, кто использовал символ вне стен монастыря, был флорентийский купец Франческо Лапи, в одном из своих писем обозначивший «собакой» амфору — стандартную в те времена меру объёма, примерно равную 26-ти л.

Постепенно знак стал приобретать и другие значения, например, в португальском, испанском и французском языках до символа «@» обычно сокращают старинную испанскую меру веса под названием «arroba», равную 11,502 кг. Символ, похожий на «собаку», исследователи обнаружили в русских книгах XVI–XVII веков, в числе которых — Судебник Ивана Грозного, датируемый 1550-м годом, а к XIX-му веку знак уже получил широкое распространение в качестве обозначения единицы товара.

Рэй Томлинсон

В 1963-м году появилась кодировка стандарта ASCII, в числе 95-ти печатных знаков которой присутствовала и «собака», а в 1973-м году члены организации «Internet Engineering Taskforce» закрепили использование знака при разделении имени и домена — эту идею в 1971-м году выдвинул программист Рэй Томлинсон. Массовой «собака» стала в 1996-м году, когда появился сервис «Hotmail».

Кстати, «собакой» символ называют лишь русские и украинцы, в других языках этот знак известен под другими, порой достаточно необычными именами. Итальянцы говорят «chiocciola» («улитка»), в Греции его знают, как «παπακι» — «уточка», в Чехии и Словакии — «zavináč» («рулетик из сельди»), на Тайване используют понятие «小老鼠» (произносится как «сяо лао шу») — «мышка», в Израиле распространено название «שטרודל» — «штрудель», а в Казахстане знак именуют «айқұлақ» — «ухо Луны».

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота