aydinlileman7
02.12.2022 12:57

Составьте программу подсчёта четных чисел числа из промежутка от 1 до 5. Выполните используя цикл с постусловием until

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Диана149018
15.06.2022 00:19

Первая задачка:

#include "stdio.h"

#include "math.h"

#include <locale.h>

int main() {

int x,pr=1;

char* locale = setlocale(LC_ALL, "");

printf("Вводите числа, чтобы окончить последовательность введите: 0\n");

do {

 scanf_s("%d", &x);

 if (x%2!=0 && x < 16 & x !=0)

 pr *= x;

} while (x != 0);

printf("%d", pr);

return 0;

}

Вторая задачка:

#include "stdio.h"

#include "math.h"

#include <locale.h>

int main() {

int a100,k=1, a1 = 5, d = 4,n=100,s=0;

a100 = a1 + d * (n - 1);

printf("%d", a100);

printf("\n");

s = ((a1 + a100) / 2) * n;

printf("%d", s);

return 0;

}

0,0(0 оценок)
Ответ:
dasha18s10
04.09.2020 07:13

9

Объяснение:

Для простоты обозначим шестерёнки номерами слева направо с 1 по 4, то есть 1 - это ведущая, 4 - ведомая.

Шестерёнки 1 и 3 одинаковые и поскольку обе находятся в зацеплении с одной шестерёнкой, у которой номер 2, то и крутиться они будут с одинаковой скоростью 15 об/мин.

Соотношение числа зубьев 3 и 4 шестерёнок 8 к 40, или что проще 1 к 5. То есть за один оборот маленькой шестерёнки большая провернётся на 1/5 своего оборота. То есть, чтобы получить количество оборотов большой шестерёнки нужно количество малой разделить на 5. При этом за 3 минуты первая и третья шестерёнки сделали 15*3 = 45 оборотов.

Значит четвёртая шестерёнка повернулась на 45/5 = 9 оборотов.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота