uchenik0012
26.03.2023 15:57

Напишите программу на Python по следующему алгоритму.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
глупыйенот
07.09.2021 03:49
Program a1;
var a,b: array [1..10] of integer; 
n,i,k,sum,c: integer;
begin
Randomize;
For i:=1 to 10 do 
   begin     
      a[i]:=random(100);     
       write(a[i]:3);   
   end;    
Readln (n);   
For i:=1 to 10 do 
   begin 
     k:=a[i];
     while k>0 do 
                    begin 
                         sum:=sum+(k mod 10);
                        k:=k div 10;
                    end; 
        f (n=sum) then  
          begin
              inc(c);     
              b[c]:=a[i];      
          end; 
 end;
for i:=1 to c do  
write(b[i]:2); 
end.
0,0(0 оценок)
Ответ:
kir123kuz123
21.03.2022 06:04
1) Program dasf;
var a,b,i,s: integer;
begin
Writeln('Введите четырёхзначное число');
readln(a);
For i:=1 to 4 do
begin
S:=a mod 10+s;
a:=a div 10
end;
writeln('Сумма цифр четырёхзначного числа:',s);
end.
2)Program sgsgsdfg;
var a,b,c,a1,b1,c1: real;
begin
Writeln('Введите а');
readln(a);
Writeln('Введите b');
readln(b);
Writeln('Введите c');
readln(c);
If (a=b) or (a=c) then a1:=a*a 
else a1:=a*2;
If (b=a) or (b=c) then b1:=b*b 
else b1:=b*2;
If (c=a) or (c=b) then c1:=c*c 
else c1:=c*2;
Writeln('Полученные числа: а=',a1,' b=',b1,' c=',c1);
end.
3) Program afgsdg;
var n,a,b,i: integer;
begin;
Writeln('Введите число');
readln(a);
Writeln('Введите степень');
readln(n);
b:=a;
For i:=2 to n do   
a:=a*b;
Writeln('Число ',b,' в степени ',n,' равно ',a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота