kkoluzhonokp08din
27.11.2020 11:27

PYTHON

Решить в действительных числах уравнение ax2 + bx + c = 0

Входные данные
На вход программе подаются a, b, c (a, b, c целые, по модулю не превосходят 30 000).

Выходные данные
Выдать код ситуации и значения корней:

•–1 — бесконечное множество решений;
• 0 — нет действительных корней;
• 1 — уравнение вырождается в линейное, выдать x;
• 2 — уравнение квадратное, два различных корня, выдать x1 и x2;
• 3 — уравнение квадратное, кратный корень, выдать x;
Значения корней выводить с двумя знаками после десятичной точки в порядке возрастания.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
grinanovatana2
25.10.2022 04:30

//PascalABC.NET v3.3 1633

var arr: array [1..6, 1..6] of integer;

begin

 for var i:=1 to 6 do

   for var j:=1 to 6 do

     arr[i, j]:=random(-49, 50);

 

 writeln('Исходный массив: ');

 for var i:=1 to 6 do

     arr[i].PrintLn(', ');

     

 var num:=0;

 for var i:=1 to 6 do

   if arr[i, 2] < 0 then num += 1;

 writeln('Количество отрицательных элементов второго столбца: '+num);

 

 for var i:=1 to 6 do

   for var j:=1 to 6 do

     if arr[i, j] > 0 then arr[i, j]:=-49;

 writeln('Новый массив: ');

 for var i:=1 to 6 do

     arr[i].PrintLn(', ');

end.

0,0(0 оценок)
Ответ:
nvede
26.02.2022 12:09

Задание 3 (двухмерный массив)

var

a:array [1..10,1..7] of integer;

k,i,j:integer;

begin

randomize;

for i:=1 to 10 do begin

for j:=1 to 7 do begin

a[i,j]:=random(9)+1;

write (a[i,j]:4);

if a[i,j] mod 2 <> 0 then k:=k+1;

end;

writeln;

end;

writeln ('Количество нечетных элементов массива = ',k);

readln;

end.

Задание 2 (двухмерный массив)

uses crt;
const
a:array [1..5,1..5] of integer = ((100,101,102,103,104),
                                                     (200,201,202,203,204),
                                                     (300,301,302,303,304),
                                                     (400,401,402,403,403),
                                                     (500,501,502,503,504));
var
i,j:integer;
begin
clrscr;
for i:=1 to 5 do begin
for j:=1 to 5 do
if j mod 2 = 0 then begin
textcolor (12);
write (a[i,j]:4);
textcolor (7);
end else begin
textcolor (9);
write (a[i,j]:4);
textcolor (7);
end;
writeln;
end;
readln;
end.

Задание 1 (одномерный массив) 

uses crt;
var
a:array [1..7] of integer;
i,sum:integer;
begin
clrscr;
for i:=1 to 7 do begin
write ('A[',i,'] = ');readln(a[i]);
if a[i]>0 then sum:=sum+a[i];
end;
for i:=1 to 7 do
if a[i]>0 then begin
textcolor (red);
write (a[i]:4);
end else begin
textcolor (blue);
write (a[i]:4);
end;
writeln;
textcolor (darkgray);
writeln ('Сумма положительных элементов = ',sum);
readln;
end.

Задание 4 (одномерный массив)

uses crt;
var
a:array [1..12] of integer;
i,buf,min,max:integer;
begin
clrscr;
randomize;
a[1]:=random(14)+1;
min:=1;
max:=2;
writeln ('Исходный массив: ');
write (a[1]:4);
for i:=2 to 12 do begin
a[i]:=random(14)+1;
write (a[i]:4);
if a[i]>a[max] then max:=i else
if a[i]<a[min] then min:=i;
end;
writeln;
{смена 1-ого и последнего эл}
buf:=a[1];
a[1]:=a[12];
a[12]:=buf;
{смена 2-ого и мин эл}
buf:=a[2];
a[2]:=a[min];
a[min]:=buf;
{смена 1-ого и макс эл}
buf:=a[1];
a[1]:=a[max];
a[max]:=buf;
writeln ('Результирующий массив:: ');
for i:=1 to 12 do write (a[i]:4);
writeln;
readln;
end.

Задание 3 (одномерный массив)

var
a,b:array [1..10] of integer;
i,j:integer;
s1,s2:real;
begin
randomize;
s1:=0;
s2:=0;
writeln;
for i:=1 to 10 do begin
a[i]:=random(11)-5;
b[i]:=random(19)-9;
write (a[i]:4);
s1:=s1+a[i];
s2:=s2+b[i];
end;
writeln;
for i:=1 to 10 do write (b[i]:4);
writeln;
s1:=s1/10;
s2:=s2/10;
if s1>s2 then writeln ('S1 > S2') else
if s1<s2 then write ('S1 < S2') else writeln ('S1 = S2');
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота