Riiiiiii
28.10.2020 18:49

PYTHON

Напишите программу для решения уравнения ax=b относительно х в целых числах. Учтите, что a может принимать любые значения, в том числе и 0.

Входные данные
На вход программе подаются целые числа a, b, по модулю не превосходящие 30 000.

Выходные данные
Требуется вывести целый корень уравнения, если он существует и единственный. Если уравнение не имеет корней, то вывести no solution. Если уравнение имеет больше одного целого корня, то вывести many solutions.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alenaefremova79
02.12.2020 21:06

Принцип последовательного кодирования алфавита заключается в том, что в кодовой таблице ASCII латинские буквы (прописные и строчные) располагаются в алфавитном порядке. Расположение цифр также упорядочено по возрастанию значений.

Стандартными в этой таблице являются только первые 128 символов, т. е. символы с номерами от нуля (двоичный код 00000000) до 127 (01111111). Сюда входят буквы латинского алфавита, цифры, знаки препинания, скобки и некоторые другие символы. Остальные 128 кодов, начиная со 128 (двоичный код 10000000) и кончая 255 (11111111), используются для кодировки букв национальных алфавитов, символов псевдографики и научных символов.

Объяснение:

0,0(0 оценок)
Ответ:
arystan307
15.05.2021 02:14

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

int main() {

setlocale(LC_ALL,"Russian");

srand(time(NULL)); //чтобы рандом каждый раз был с разными значениями

int a[1000],b,n;

cout<<"Введите размер массива "<<endl;

cin>>n;

cout<<"Исходный массив: "<<endl;

for (int i=1;i<=n;i++)

{

 a[i]=rand() % 99;

 cout<<a[i]<<" ";

}

for (int i=1;i<n;i++)

{

 if(a[i]>a[i+1])

 {

  b=a[i];

  a[i]=a[i+1];

  a[i+1]=b;

  i=0; //возвращаемся в начало массива

 }

}

cout<<endl<<"Отсортированный массив: "<<endl;

   for (int i=1;i<=n;i++)

{

 cout<<a[i]<<" ";

}

 

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота