vikhrovdavid
01.03.2023 05:34

Народ, кто может В массиве с именем а, содержатся 10 натуральных чисел (числа для каждого

задания придумать самим таким образом, чтобы результат программы не был равен

0. Составить программу по своему варианту

1) Найти количество (k) нечетных элементов массива

2) Найти произведение (p) элементов массива, которые оканчиваются на 3

Программа: thonny-3.2.6

Ребят В информатике вообще не шарю(

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vadimnigamaev
03.07.2022 06:32

Начало отсчета лет - 1984 год. Надо написать программу (pascalABC). Вводите год, нужный вам, отнимаете от него 1984 и находите остаток от деления на 12. Последовательность животных в 12-летнем цикле - крыса, корова, тигр, заяц, дракон, змея, лошадь, овца, обезьяна, курица, собака, свинья. То есть если при делении на 12 остаток равен 0, значит введенный год - год крысы, если 1 - год коровы и т.д.

Программа: 

var a,b,c:longint;
begin
write('Введите год: ');
readln(a);
c:=a-1984;
b:=c mod 12;
case b of
0:writeln(a,' - год крысы');
1:writeln(a,' - год коровы');
2:writeln(a,' - год тигра');
3:writeln(a,' - год зайца');
4:writeln(a,' - год дракона');
5:writeln(a,' - год змеи');
6:writeln(a,' - год лошади');
7:writeln(a,' - год овцы');
8:writeln(a,' - год обезьяны');
9:writeln(a,' - год курицы');
10:writeln(a,' - год собаки');
11:writeln(a,' - год свиньи');
end;
end.

0,0(0 оценок)
Ответ:
Brosherin
05.01.2022 14:20

64       125            840

 

89       150        865                      25 + 125 - 36 * 5 : 2 = 285. Так как х с противоположными                                      

                                                                                                         знаками, то мы их убираем. И                                                     

214     275        990                                                                       получается 285.

 

178    239       954

 

114    114        114

 

570      570      570

 

285    285        285

 

285    285        285

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота