Olegggg04
01.06.2022 01:01

Написать программу вычисления модуля произведения отрицательных чисел, если индекс ячейки нечётное число.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DanilKrut11
13.10.2020 23:28

Program Primer;

var A: Array[1..20] Of Integer;

     i, n, s, p: Integer;

begin

    write ('n=');  

    readln (n);

    for i:=1 to n do readln (A[i]);   {ввод массива}                 s:= 0;  p:=1;

    for i:=1 to n do   {обработка массива}

    if (A[i] mod 2 <>0) and (A[i] mod 3 = 0) then

     begin

         s:=s+A[i];  

         p:= p*A[i];

     end;

    writeln ('s=', s, 'p=', p);

    readln;

    end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота