DASHAMIronovAAA
14.08.2021 10:51

На C++
1. Даны два числа. Равны ли они друг другу.
2. Составить программу определяющую принадлежит ли точка с координатами (х,у) графику функции y=4*x*x+9
3. Дано трехзначное число. Чётна ли его средняя цифра

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
volkovaw
25.04.2023 20:50
1)
#include <iostream>

using namespace std;

int main() {
  int s = 0;
  for(int i = 1; i < 101; cout << i << ' ', s+=i, i+=2);
  cout << endl << s << endl;
}
2)
#include <iostream>

using namespace std;

int main() {
  int n, k = 0;
  cin >> n;
  for(int i = 0; i < n; i++) {
    int number;
    cin >> number;
    if(number % 2 == 0) k++;
    else k--;
  }
  if(k > 0) cout << "Четных" << endl;
  else if (k < 0) cout << "Нечетных" << endl;
  else cout << "Одинаково" << endl;
}
3)

#include <iostream>

using namespace std;

int main() {
 for(int i = 20; i < 51; i++)
   if(i % 3 == 0 && i % 5 != 0) cout << i << endl;
}
4) 
#include <iostream>

using namespace std;

int main() {
 for(int i = 35; i < 88; i++)
   if(i % 7 == 1 || i & 7 == 2 || i % 7 == 5) cout << i << endl;
}
0,0(0 оценок)
Ответ:
1KoTObOpMoT1
15.05.2022 00:30
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота