aleksandrp462
13.09.2020 03:42

Составить программу с использованием условного оператора if then else для решения уравнения y=3x+7: x-8информатика 8 класс​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Георгий20004
15.08.2020 07:03
I.
1. информационными моделями являются - ..
в)модель корабля
г)химическая формула

2. материальной моделью является - ..
а)анатомический муляж

3. какие пары объектов находятся в отношении "объект-модель"
б)компьютер-его функциональные схемы

4. какая модель является статической?
в)формула химического соединения

II.
1. имя переменной определяет - ..
б)выделенную область оперативной памяти

2. значение переменной определяет - ..
а)данные хранящиеся в выделенной области оперативной памяти
б)данные хранящиеся в выделенной области оперативной памяти

3. тип переменной определяет - ..
в)количество выделяемых ячеек оперативной памяти
г)присваивание значения переменной

III.
1. операционная система - это ..
в)программа управляющая работой компьютера

2. системные диск необходим для ..
а)загрузки операционной системы

3. отличительной особенностью компьютерных вирусов от других вредоносных программ является- ..
б к размножению

4. информационный объем файла не может быть больше, чем ..
а)размер сектора диска
0,0(0 оценок)
Ответ:
sbordog1337bogdan
10.08.2020 12:32

//первая программа

var
   a:array[1..10] of integer;
   Sr, i:integer;
 begin
   Sr := 0;
   for i := 1 to 10 do
   begin
     write('a[', i, '] = ');
     readln(a[i]);
     if i mod 2 = 0 then
       Sr := Sr + a[i];
   end;
   writeln('Среднее арифметическое элементов стоящих на четных местах: ', Sr /(10 div 2));
 end.

 

 

//вторая программа

var
  a:array[1..3, 1..3] of integer;
  Pr, count, summ, i, j:integer;
begin
  pr := 1;
  summ := 0;
  count := 0;
  for i := 1 to 3 do
    for j := 1 to 3 do
    begin
      write('a[', i, ', ', j, '] = ');
      readln(a[i, j]);
      if i mod 2 = 1 then
        pr := pr * a[i, j];
      if a[i, j] < 0 then
      begin
        summ := summ + a[i, j];
        count := count + 1;
      end;
    end;
  writeln('Произведение элементов стоящих в четных строках: ', pr);
  if count <> 0 then
    writeln('Среднее арифметическое отрицательных элементов: ', summ / count)
  else
    writeln('Нет ни одного элемента отрицательного элемента');
end.
   

 

//третья программа

var
  s:string;
  c:char;
  i:integer;
begin
  s := 'Мадагаскар';
  writeln('Исходная строка: ');
  writeln(s);
  for i := 1 to Length(s) div 2 do
  begin
    c := s[i];
    s[i] := s[Length(s) - i + 1];
    s[Length(s) - i + 1] := c;
  end;
  writeln('Перевернутая строка:');
  writeln(s);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота