juwal
26.01.2020 18:15

Практические работы по информатике по теме
«Алгоритмизация и программирование»»
Практическя работа №1.
1. Переведите слова Python и print с английского языка на русский.
Python ¬ print ¬
2. Вася решил дополнить программу так, чтобы она выводила сообщение с его именем. Он записал оператор вывода так:
print 'Привет', Вася!
Эта программа не работает. Запишите правильный вариант:

К какому типу относится эта ошибка?

3. Требуется написать программу, которая складывает два числа и выводит на экран их сумму. Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
4. Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
5. В языке Python целые переменные относятся к типу (классу) int. Выясните, откуда произошло сокращение int в языках программирования:
int – это сокращение от английского слова , которое переводится как .
6. Выделите красным фоном недопустимые имена переменных:
1 Vasya СУ-27 @mail_ru
m11 Петя СУ_27 lenta.ru
1m Митин брат _27 "Pes barbos"
m 1 Quo vadis СУ(27) <Ладья>

7. Что появится на экране после выполнения программы:
c = 5
print( с )
print( 'c' )
ответ:
Чем отличаются два оператора вывода в программе?
Место для ввода текста.
8. Что выведет на экран программма
a = 1
print( a )
a = 5
print( a ) ответ:
Заполните пропуски: «Если переменной присваивается новое значение, то предыдущее значение .»
Выберите правильный вариант: «Переменная в любой момент может иметь ».
9. Чему будут равны значения переменных a и b после выполнения программмы, если вначале они имели значения a = 4 и b = 7? Выполните ручную прокрутку программы.
a b
4 7
a = a + 1
b = b + 1
a = a + b
b = b + a
a = a + 1
ответ: a = b =
10. Что выведет эта программа при a = 4, b = 5 и c = 9?
print( 'a', '+b', =, c )
Место для ввода текста.
11. Исправьте ошибки в операторе вывода,
print( 'c', '-b', =, a )
чтобы при a = 4, b = 5 и c = 9 программа вывела 9–5=4:
Место для ввода текста.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Alinatkd
07.05.2023 18:25

1 непрерывный (сигнал)

2 ( происходит его) оцифровка

3 дискретный, цифровой (сигнал)

4  (называется) глубиной кодирования звука

5 (расчитать) информационный объем файла

6 (N-это) количество уровней громкости звука

7 (І-ЭТО) глубина кодировки звука

8 (зависит от) частоты дискретизации

9 глубины звука (за) секунду

10 (V- это) - частота дискретизации измеряется в герцах

(f -это) - глубина дискретизации измеряется в битах

(t-это) -время звучания или записи измеряется в секундах

(К определяет количество) каналов

если моно к= 1, если стерео к= 2, если квадро к= 4

Объяснение:

0,0(0 оценок)
Ответ:
miheeva74
15.08.2021 07:32
Сначала код без комментариев:

Var
S:longint;
i:integer;
A:byte;

Begin
S:=0;
Repeat
   Read(A);
   if (A mod 2 <> 0)and(A mod 7 = 0) then S:=S+A;
Until A = 0;
WriteLn('S = ',S);
End.

Теперь объяснение каждой строки:

Var
S:longint;
i:integer;
A:byte; // В эту переменную будет вводится число с клавиатуры. Тип Byte может принимать значения от 0 до 255. Поэтому его как раз хватит.

Begin
S:=0; // Тут будет храниться сумма, поэтому переменную следует сперва обнулить.

Repeat // далее начинается цикл
   Read(A); // эта команда каждый раз считывает с клавы число, и записывает его в переменную A.

   if (A mod 2 <> 0)and(A mod 7 = 0) then S:=S+A; //тут проверяется 2 условия, и если они выполняются - к переменной S прибавляется значение переменной А
   1 условие: число нечётно, то есть остаток от деления его на 2 не равен нулю (A mod 2 <>0)
   2 условие: Число кратно 7, то есть делится без остатка на 7, то есть остаток от деления равен нулю (A mod 7 = 0)

Until A = 0; // Цикл повторяется до тех пор, пока введённое с клавы число не будет равно нулю (A = 0)

WriteLn('S = ',S); // Тут выводится искомая сумма
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота