пикачу87
16.12.2022 19:45

Исправьте ошибку , я выполнял задание
Напишите программу, которая для произвольного натурального двузначного числа определяет сумму и произведение его цифр

var x, a, b, c, d: integer;
begin
writeln ('число');
readln (x);
a:=x mod 10 ;
b:=x mod 10;
c:=a*b;
d:=a+b;
writeln ('произведениеc=', c);
writeln ('сумма=', d);
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Daniluha29
29.04.2021 08:19
#include <iostream>
#include <vector>
using namespace std;

int main() {
    unsigned short int n;
    cout << "n = ";
    cin >> n;
    vector<int> a;
    int in,
        avg,
        s = 0,
        c = 0;
    for (int i = 0; i < n; ++i) {
        cout << "a[" << i << "] = ";
        cin >> in;
        a.insert(a.end(), in);
        if (i % 2 == 1) {
            s += a.back();
            c++;
        }
    }
    avg = (int) s / c;
    cout << "Среднее арифметическое элементов на нечётных позициях: "
         << avg;
    return 0;
}
0,0(0 оценок)
Ответ:
nikitaviktorov9
21.04.2020 03:46
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  SeqGen(ReadInteger('n='),i->1/(1+i)).Sum.Println; // №1
  // №2
  var a:=ArrGen(9,i->(i+1)*Sqr(i+1)); a.Println;
  Writeln('Кол-во=',a.Length,', S2=',a.Sum);
  Writeln('S3=',Range(2,100,2).Println.Sum); // №3
  Writeln('S4=',Range(1,99,2).Sum) // №4
end.

Пример
n= 65
4.75927551909038
1 8 27 64 125 216 343 512 729
Кол-во=9, S2=2025
2 4 6 8 10 12 14 16 18 20 22 24 26 28 30 32 34 36 38 40 42 44 46 48 50 52 54 56 58 60 62 64 66 68 70 72 74 76 78 80 82 84 86 88 90 92 94 96 98 100
S3=2550
S4=2500
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота