Шатунов1
29.03.2021 07:50

Написать программу
очень надо
найдите двузначное число, равное квадрату числа его единиц, сложенному с кубом его десятков. сколько существует таких чисел?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kamilapark1
14.12.2022 00:44
#include <iostream>
#include <conio.h>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    unsigned long long A,B;
    cout << "Введите A(Начало) и B(Конец):\t";
    cin >> A >> B;
    if (A>0)
        for (unsigned long long i=A; i<=B; i++)
            cout << i << "\t - \t" << i*i << endl;
    else
    {
        cout << "Ошибка!";
        _getch();
        return -1;
    }
    _getch();
    return 0;
}

P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.
0,0(0 оценок)
Ответ:
AvgustinaQueen
13.11.2021 06:44

* Так как нужно найти количество последовательностей, содержащих ровно 3 буквы А, то отбрасываем А при подсчете:
   3 - 1 = 2.
* Остается две буквы: Б и В, которые могут дать следующие последовательности:
  ББ
  БВ
  ВБ
  ВВ
Всего 4 последовательности, теперь составим список количества возможных последовательностей, в котором ровном 3 буквы А:
  ААА**
  АА**А
  АА*А*
  *АА*А
  А**АА
  А*А*А
  А*АА*
  **ААА
  *А*АА
  *ААА*
* Всего 10 возможных вариантов: 10 * 4 = 40 различных последовательностей, содержащих ровно 3 буквы А.

ответ: 40

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота