Кепики
12.02.2022 18:50

Напишите программу определения суммы членов ряда с точностью e=10^3, общий член которого an задан формулой: an = xn (2n-1) / n!

2-вр. an = x/n2;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
6lackk
21.06.2021 02:38

#include <iostream>

int main() {

using namespace std;

setlocale(LC_ALL, "Russian");

int N;

cout << "Введите размерность массива: ";

cin >> N;

int* A = new int[N];

for (int i = 0; i < N; i++)

{

 cout << "Заполните [" << i + 1 << "] элемент: ";

 cin >> A[i];

}

cout << endl;

for (int i = 0; i < N; i++)

{

 cout << A[i] << " ";

}

int max_index = 0;

for (int i = 1; i < N; i++)

{

 if (A[i] > A[max_index]) {

  max_index = i;

 }

}

cout << "\nНомер локального максимума: " << max_index + 1;

return 0;

}

0,0(0 оценок)
Ответ:
polinapiterskog
25.10.2021 22:09

--- PascalABC.NET 3.6.2 ---

//Без внятного ТЗ - Результат ХЗ (с) Конфуций, 488 год до Н.Э.

begin

 var AvaiableTravels := new List<(string, integer)>(10);

 var RawInput: array of string;

 for var i := 1 to 10 do begin

   RawInput := ReadString($'{i} Enter Travel info (Country:Price)').Split(':');

   AvaiableTravels.Add((RawInput[0], integer.Parse(RawInput[1])));

 end;

 

 var TotalCost : integer;

 var MaxCost: (string, integer) := AvaiableTravels.First;

 var MinCost: (string, integer) := AvaiableTravels.Last;

 

 AvaiableTravels.ForEach(p -> begin  

 TotalCost += p.Item2;

 if p.Item2 > MaxCost.Item2 then MaxCost := p;

 if p.Item2 < MinCost.Item2 then MinCost := p;

 end);

 

 Println($'Total Travel Cost: {TotalCost}',

 $'Most expensive Travel: {MaxCost}',

 $'Most poor travel: {MinCost}');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота