olyakak00Fokcu
22.06.2022 00:14

РЕШИТЬ В СРЕДЕ PYTHON
Программа переводит целое число секунд s в запись типа:
«x1 месяц х2 день х3 час х4 минута х5 секунда».
На входе: целое число секунд s.
На выходе: строка, содержащая целые числа.
Входные данные:
127412
Выходные данные:
0 месяц 1 день 35 час 2123 минута 127412 секунда

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
juliajulia005
25.05.2020 04:13

Задача 1:

var x:longint;

   i,c,sum:integer;

begin

   c:=0;

   sum:=0;

   write('Введите число: '); readln(x);

   while x <> 0 do begin

       i:=x mod 10;

       x:=x div 10;

       

       if i mod 2 = 0 then begin

           c:=c+1;

           sum:=sum+i;

       end;

   end;

   if c > 0 then write('Среднее арифметическое всех чётных чисел равно: ', sum/c:0:2)

   else write('Чётных цифр нет!');

end.

Задача 2:

var x,y,sum:integer;

begin

   sum:=0;

   y:=0;

   while True do begin

       write('Введите число: '); readln(x);

       if x = 0 then break

       else if abs(x-y) > sum then sum:=abs(x-y);

       y:=x;

   end;

   write(sum);

end.

0,0(0 оценок)
Ответ:
MrSasha1111
30.12.2022 19:08

   class Program

   {

       static void Main(string[] args)

       {

           int a = int.Parse(Console.ReadLine());

           int b = int.Parse(Console.ReadLine());

 

           int x = int.Parse(Console.ReadLine());

           int y = int.Parse(Console.ReadLine());

           int z = int.Parse(Console.ReadLine());

 

           if (x <= a && y <= b || y <= a && x <= b ||

               x <= a && z <= b || z <= a && x <= b ||

               z <= a && y <= b || y <= a && z <= b)

               Console.WriteLine("Пройдет");

           else

               Console.WriteLine("Не пройдет");

 

           Console.ReadKey();

       }

   }

Объяснение:

.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота