bayramovarzu
15.07.2020 11:28

Написать программу которая методом обмена пузырька сортирует по убыванию введённый с клавиатуры одномерный массив .(с++)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sherlock0w
22.05.2020 05:41

#include <iostream> //подключаем библиотеку iostream

using namespace std;

int main()

{

int a, s; //объявляем целочисленные переменные a и s

cin >> a; //вводим a

s = 0; //обнуляем сумму

 while (a != 0) //цикл while, условие - a не равно нулю

 {

  s = s + a % 10; //остаток от деления числа на 10 - его последняя цифра, прибавляем ее к сумме

  a = a / 10; // убираем последнюю цифру

 }

if (s % 2 == 0) //условие - проверка на четность

{

 cout << "summa chetnaya"; //выводим когда сумма четная

}

else

{

 cout << "summa nechetnaya"; //выводим когда сумма нечетная

}

return 0;

}

0,0(0 оценок)
Ответ:
2424r
26.03.2021 02:39

Язык Паскаль был создан Никлаусом Виртом в 1968—1969 годах после его участия в работе комитета разработки стандарта языка Алгол-68. Язык назван в честь французского математика, физика, литератора и философа Блеза Паскаля, который создал первую в мире механическую машину, складывающую два числа.

Блез Паскаль появился на свет 19 июня 1623 года в городке Клермон-Ферран на юге Франции.

в 1640 году свет увидел «Опыт теории конических сечений», ставший основополагающим трактатом для дальнейших трудов в области геометрии.

в 1642 году Блез занимался разработкой чудо-аппарата. Его арифмометр, сделанный по принципу античного таксометра, выглядел как ящик с многочисленными шестеренками и позволял производить расчеты с шестизначными числами, а подсчет производился в полуавтоматическом режиме.

В конце 1646 года Блез Паскаль, узнав о трубке, изобретенной Торричелли, стал увлекаться физикой. Ученый начал ставить эксперименты, доказывая, что гипотеза Аристотеля о «боязни пустоты» имеет пределы.

Блез видоизменил этот эксперимент и сделал заключение, что верхняя часть трубки не наполнена парами химического вещества, тонкой материей или иной субстанцией. Результаты своей работы Паскаль опубликовал в трактате «Новые опыты, касающиеся пустоты», а далее стремился прийти к выводу, что столбик с ядовитым металлом удерживается давлением воздуха.

Кроме того, Блез Паскаль выпустил в свет рукопись «Трактат о равновесии жидкостей» (1653), сформировал идею гидравлического пресса и установил основной закон гидростатики, опровергнув учение древнегреческого философа.

в 1652 году удостоился признания и славы, презентовав свою суммирующую машинку шведской королеве Кристине.

Умер в 1662 году, Париж, Франция.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота