Cat6661313
21.10.2020 09:12

написать программу на алгоритмическом языке по этой схеме

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gan1298
30.08.2020 03:28

у нашего робота тоже есть система команд. сегодня мы рассмотрим простые команды робота. всего их 5:

вверх

вниз

влево

вправо

закрасить

результат выполнения этих команд понятен из их названия:

вверх — переместить робота на одну клетку вверх

вниз — переместить робота на одну клетку вниз

влево — переместить робота на одну клетку влево

вправо — переместить робота на одну клетку вправо

закрасить — закрасить текущую клетку (клетку в которой находится робот).

эти команды можно писать с клавиатуры, а можно использовать горячие клавиши (нажав их команды будут вставляться автоматически):

вверх — escape, up (стрелка вверх)

вниз — escape, down (стрелка вниз)

влево — escape, left (стрелка влево)

вправо — escape, right (стрелка вправо)

закрасить — escape, space (пробел)

если такое окно робота у вас не появилось, то на панели инструментов щелкните «показать окно робота» или в меню робот выберите пункт «показать окно робота«. продолжаем дальше.

теперь мы будем двигаться вниз и закрашивать правую сторону квадрата:

вниз

закрасить

вниз

закрасить

потом пойдем влево, закрашивая нижнюю границу квадрата

влево

закрасить

влево

закрасить

у нас осталась одна незакрашенная   клетка. закрасим ее

вверх

закрасить

все готово! в итоге наша программа выглядит так:

использовать робот

алг квадрат

нач

закрасить

вправо

закрасить

вправо

закрасить

вниз

закрасить

вниз

закрасить

влево

закрасить

влево

закрасить

вверх

закрасить

кон

0,0(0 оценок)
Ответ:
arsenmalhasan20
21.09.2021 02:03

вот код:

var a,b,c,d,e,min,max: integer;

begin

read (a,b,c,d,e);

if (a> b) and (a> c) and (a> d) and (a> e) then max: = a;

if (b> a) and (b> e) and (b> c) and (b> d) then max: = b;

if (c> a) and (c> b) and (c> d) and (c> e) then max: = c;

if (d> a) and (d> c) and (d> b) and (d> e) then max: = d;

if (e> b) and (e> a) and (e> d) and (e> c) then max: = e;

if (a< b) and (a< c) and (a< d) and (a< e) then min: = a;

if (b< a) and (b< e) and (b< c) and (b< d) then min= b;

if (c< a) and (c< b) and (c< d) and (c< e) then min: = c;

if (d< a) and (d< c) and (d< b) and (d< e) then min: = d;

if (e< b) and (e< a) and (e< d) and (e< c) then min: = e;

writeln ('минимальное число: ',min);

writeln ('максимальное число: ',max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота