айскримву
21.10.2022 02:36

1.Составьте программу, которая выводит на экран таблицу значений функции y=sin(x).
2.Составить программу рисования следующей последовательности однотипных фигур:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
FarmFarm
02.01.2022 22:47

а — для осуществления хранения, поиска и сортировки данных.

б — реляционные и иерархические (древовидная).

в — простота использования и возможность использования формального аппарата математики для обработки.

г — запись в таком виде представляет собой значение поля, соответствующее заранее определенному признаку, названию, типу в таблице.

д — поле — ячейка для хранения переменной, тип поля — предполагаемое математическое выражение, служащее для описания возможного значения поля, бывают различные типы полей: строка, массив байт, целое число, дробное число и т.д.

е — ключ — идентификатор строки, служащий для однозначного сопоставления с другими сроками в других таблицах, иногда является индексом сортировки. Также ключ сохраняет целостность структуры данных.

Объяснение:

0,0(0 оценок)
Ответ:
5655к
09.04.2023 11:08
//Pascal ABC.NET v3.1 сборка 1172

var
  ar: array of integer;
  n, k2, k3, k4, k5, i: integer;
  r: real;

begin
  write('Сколько учеников?');
  readln(n);
  setlength(ar, n);
  writeln('Введите оценки:');
  for i := 0 to n - 1 do
  begin
    readln(ar[i]);
    case ar[i] of
      2: inc(k2);
      3: inc(k3);
      4: inc(k4);
      5: inc(k5);
    else
      writeln('Не оценка');
      exit;
    end;
  end;
  writeln('2:', k2);
  writeln('3:', k3);
  writeln('4:', k4);
  writeln('5:', k5);
  write('Успеваемость=', (k3 + k4 + k5) / n * 100:0:1);
end.

Пример ввода:
Сколько учеников?6
Введите оценки:
2
2
3
4
5
5
Пример вывода:
2:2
3:1
4:1
5:2
Успеваемость=66.7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота