АннаЕжиха
15.01.2020 04:47

Нужно написать программу Нужен номер под "е".
Дано натуральное число n, действительное число x. Вычислить:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katya8998
19.03.2020 17:11
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=SeqRandom(ReadInteger('n='),-1000,1000).Select(t->t/100).ToArray;
  a.Println;
  a.Transform(t->t.Between(-4.7,-0.1)?t:-t); a.Println
end.

Пример
n= 10
6.6 -4.4 -2.21 -4.95 -7.26 1.38 -5.8 0.77 -4.41 3.31
-6.6 -4.4 -2.21 4.95 7.26 -1.38 5.8 -0.77 -4.41 -3.31

begin
  var n:=ReadInteger('n=');
  var (max,k,tmp):=(integer.MinValue,0,0);
  loop n do begin
    Read(tmp);
    if tmp>max then (max,k):=(tmp,1)
    else if tmp=max then k+=1
    end;
  Writeln('Максимум ',max,' встречен ',k,' раз(а)')
end.

Пример
n= 8
-6 -9 12 7 -5 12 10 -3
Максимум 12 встречен 2 раз(а)
0,0(0 оценок)
Ответ:
Dedsec08
31.10.2022 19:28
Для начала следует отметить тот факт, что не следует путать оператор присваивания со знаком равенства в математике.
Оператор присваивания работает следующим образом. (на примере k := 4+7) Сначала вычисляется значение выражения справа от оператора (4+7 = 11), затем результат вычисления "записывается" в переменную из левой части оператора. В результате по имени этой переменной можно получить записанное значение и даже использовать его в других выражениях.

"а := 17" Записываем в переменную а значение 17.

"b := 23" Записываем в переменную b значение 23.

"b := а + b + 1" Сначала вычисляем выражение a+b+1 = 17+23+1 = 41. Затем изменяем значение переменной b (теперь она хранит в себе 41)

"а := b + а" Сначала вычисляем выражение b+a = 41+17 = 58. Затем изменяем значение переменной a (теперь она хранит в себе 58)

ответ: 58
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота