EpicKsushaGames
18.02.2023 16:20

Написать программу, работающую с массивом структур со следующими полями Написать программу, работающую с массивом структур со следующими полями:
• Номер поезда;
• Маршрут следования;
• Среднее опоздание за рейс.
Программа должна позволять ввести новые данные, вывести содержимое массива на
экран, вывести информацию по поезду с максимальным опозданием, выйти из
программы. Все действия программы организовать с функций.
Рекомендации: Основная функция только реализует главное меню. Действие каждого
пункта меню выполняет отдельная функция.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sashashola
11.03.2022 09:26
1)Графический редактор–это программа, предназначенная специально для рисования и редактирования изображений. Точнее, программа позволяющая вам создавать настоящие шедевры живописи прямо на вашем компьютере, или редактировать уже за ранее готовые фотографии и изображения (простой пример возможностей редактора — убрать распространенный «эффект красных глаз»).
2)Растр — изображение, построенное из отдельных элементов (точек), как правило, расположенных регулярно. В большинстве приложений компьютерной графики, растровое изображение представляется двумерным массивом точек, цвет и яркость каждой из которых задаются независимо.
Пиксел — это наименьшая единица растрового изображения, получаемого с графических систем вывода информации (компьютерные мониторы, принтеры и т. д.)
4)Графический примитив - простейший геометрический объект, отображаемый на экране дисплея или на рабочем поле графопостроителя: точка, отрезок прямой, дуга окружности или эллипса, прямоугольник и т.п.
5)Векторная графика состоит из точек линий квадратов. Качество не ухудшается при увеличении. Используется в больших плакатах, гербах...
6)Качество растрового изображения зависит от размера изображения (количества пикселей по горизонтали и вертикали) и количества цветов, которые можно задать для каждого пикселя.
7)Растровая графика позволяет создать практически любой рисунок, вне зависимости от сложности, в отличие, например, от векторной, где невозможно точно передать эффект перехода от одного цвета к другому без потерь в размере файла.
Распространённость — растровая графика используется сейчас практически везде: от маленьких значков до плакатов.
Высокая скорость обработки сложных изображений, если не нужно масштабирование.
Растровое представление изображения естественно для большинства устройств ввода-вывода графической информации, таких как мониторы (за исключением векторных устройств вывода), матричные и струйные принтеры, цифровые фотоаппараты, сканеры, а также сотовые телефоны.
0,0(0 оценок)
Ответ:
rustik1619
25.09.2020 01:43

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int k;

   cin >> k;

   int minutes, hours, seconds;

   hours = k / 3600;

   minutes = k % 3600 / 60;

   seconds = k % 3600 % 60;

   cout << "Часов: " << hours << " Минут: " << minutes << " Секунд: " << seconds;

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека локализации (возможно, будет работать и без нее)

using namespace std;  // Пространство имён

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация в консоли (возможно, будет работать и без нее)

   int k;  // Переменная, хранящая секунды

   cin >> k;  // Ввод

   int hours, minutes, seconds;  // Переменные для хранения часов, минут и секунд

   hours = k / 3600;  // Часы

   minutes = k % 3600 / 60;  // Минуты

   seconds = k % 3600 % 60;  // Секунды

   cout << "Часов: " << hours << " Минут: " << minutes << " Секунд: " << seconds;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота