coolbembel
05.01.2021 06:42

Pascal. Напишите программу. Задание: Выводить посимвольно на экран предложение до тех пор, пока не будет введён символ «точка».

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Reixerrr
16.07.2020 15:28
Исходное число 665675757
1)665675757:2=332837878 и в остатке 1
значит пишем 1
2)332837878:2=166418939 и в остатке 0
значит пишем 0
3)166418939:2=83209469 и в остатке 1
значит пишем 1
4)83209469:2=41604734 и в остатке 1
значит пишем 1
5)41604734:2=20802367 и в остатке 0
значит пишем 0
6)20802367:2=10401183 и в остатке 1
значит пишем 1
7)10401183:2=5200591 и в остатке 1
значит пишем 1
8)5200591:2=2600295 и в остатке 1
значит пишем 1
9)2600295:2=1300147 и в ост 1
зн пишем 1
10)1300147:2=650073 и в ост 1
зн пишем 1
11)650073:2=325036 и в ост 1
зн пишем 1
12)325036:2=162518 и в ост 0
зн  пишем 0
13)162518:2=81259 и в ост 0
зн пишем 0
14)81259:2=40629 и в ост 1
зн пишем 1
15)40629:2=20314 и в ост 1
зн пишем 1
16)20314:2=10157 и в ост 0
зн пишем 0
17)10157:2=5078 и в ост 1
зн пишем 1
18)5078:2=2539 и в ост 0
зн пишем 0
19)2539:2=1269 и в ост 1
зн пишем 1
20)1269:2=634 и в ост 1
зн пишем 1
21)634:2=317 и в ост 0
зн  пишем 0
22)317:2=158 и ост 1
зн пишем 1
23)158:2=79 и ост 0
зн пишем 0
24)79:2=39 и ост 1
зн пишем 1
25)39:2=19 и ост 1
зн пишем 1
26)19:2=9 и ост 1
зн пишем 1
27)9:2=4 и ост 1
зн пишем 1
28)4:2=2 и ост 0
зн пишем 0
29)2:2=1 и ост 0
зн пишем 0
30)1:2=0 и ост 1
зн пишем 1
число в двоичной системе 10110111110011010110101111001
0,0(0 оценок)
Ответ:
Koroleva12112002
15.11.2021 04:52
1 задача. Если есть ошибка или можно подругому сделать напишите. 
  class Program   
 {        
class Skier        
{            
public const float procent = 0.12f;           
public float distance = 7f;            
public float multiplication;            
public float alldistance;            
public float totalmileage = 7f;

public float Mileage(int day)          
  {                if (day == 1)                   
 {                        return alldistance = distance ;                    } 
  else if (day >= 2 )               
 {                    for (int i = 2; i <= day; i++)                 
   {                        
multiplication = distance * procent;                       
 alldistance = distance + multiplication;                      
  distance = alldistance;                   
 }    
    }
                return alldistance;                        
   }
 public float TotalPath(int days)            
 {                if (days == 1)               
 {                    return totalmileage = distance;                }
                else if (days >= 2)                
{                    for (int i = 2; i <= days; i++)                   
 {                        
multiplication = distance * procent;                        
alldistance = distance + multiplication;                     
   distance = alldistance;                        
totalmileage += alldistance;               
 }               
 }                
return totalmileage;          
  }
  }
 static void Main(string[] args)      
  {            
Skier skier = new Skier();
Console.WriteLine("Пробег лыжника за n дней тренировок, введите n: ");            skier.Mileage(Convert.ToInt32(Console.ReadLine()));            Console.WriteLine("Пробег: "+ skier.alldistance);
 Console.WriteLine("Суммарный путь за m дней, введите m: ");            skier.TotalPath(Convert.ToInt32(Console.ReadLine()));            Console.WriteLine("Суммарный путь: " + skier.totalmileage);
     Console.ReadLine();      
  }    }

Задача 2. Решил ее так как я сам понял..

class Students    {      
 List<int> numbers = new List<int>();       
public int countstudents;       
public int maxCount;        
public int minCount;        
public void clas(int n)       
 {          
  for (int i = 1; i <= n; i++)           
 {                   
Console.WriteLine("Введите кол-во учеников в классе: " );                 
countstudents = Convert.ToInt32(Console.ReadLine());                   
numbers.Add(countstudents);
}
maxCount = numbers.Max();               
minCount = numbers.Min();                
Console.WriteLine("Численность превышает на: " + (maxCount-minCount) + " ученика/ов");                  
}
 static void Main(string[] args)        {
 Students students = new Students();            
Console.WriteLine("Введите кол-во классов: ");            students.clas(Convert.ToInt32(Console.ReadLine()));           
 Console.ReadLine();
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота