Ruta12340
25.01.2021 16:07

Напишите программу, которая для заданного целого числа определяет:

а) является ли число четным;

б) оканчивается ли оно цифрой 5.

Для решения задачи вспомните операцию mod (остаток от деления) и составьте логические выражения для ответа на во задачи.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
deniskin278
13.09.2020 19:58

ответ:Ох уж и не думал что вернусь в этот язык

Объяснение:

program название;

var a;

Begin

Writeln ("Введите число:");

Readln(a);

if (a mod 2 <> 1) then Write("Число нечетно");

else write ("Число чётное");

if (a mod 5 <> 5 and a mod 10 <> 5) then write ("Число не оканчивается на 5")

else Write ("Число оканчивается на 5");

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота