Фёкла11
20.09.2022 19:38

С ПРОГРАММОЙ PYTHON
Текст длиной К символов записан с алфавита мощностью М. Определите количество информации в сообщении, закодированном с равномерного двоичного кода наименьшей длины.

Программа получает натуральные числа К, М и единицу измерения информации (бит, байт или Кбайт). Требуется вывести количество информации в заданной единице измерения, округленного до целого.
(Например: входные данные 160, 26, байт; выходные данные 100)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
progamesnester
05.11.2022 22:38
1)
#include <iostream>
#include <math.h>

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 string s = "yes";
 while(abs(a) > 0) {
   if(a%10 != d) {
     s = "no";
     break;
   }
   a/=10;
  }
  cout << s << endl;
}
2)
#include <iostream>
#include <math.h>

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 a/=10;
 string s = "no";
 while(abs(a) > 0) {
  if(a%10 == d) {
    s = "yes";
    break;
  }
  d = a%10;
  a/=10;
  }
  cout << s << endl;
}
0,0(0 оценок)
Ответ:
SchneiderOK
05.11.2022 22:38
1)
#include <iostream>
#include <math.h>

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 string s = "yes";
 while(abs(a) > 0) {
   if(a%10 != d) {
     s = "no";
     break;
   }
   a/=10;
  }
  cout << s << endl;
}
2)
#include <iostream>
#include <math.h>

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 a/=10;
 string s = "no";
 while(abs(a) > 0) {
  if(a%10 == d) {
    s = "yes";
    break;
  }
  d = a%10;
  a/=10;
  }
  cout << s << endl;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота