Войти
Регистрация
Спроси ai-bota
Вика1609000
24.10.2020 14:30
Первые десять элементов массива Х размерностью 30 вычисляются по
формуле X[i]=i+3, а остальные - X[i]=5*i-10. Выведите полученный
массив.
На паскале
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
rufergem
25.12.2021 09:07
Күнделікті адам өмірінде сымсыз желі неліктен маңызды ?...
bubles13
22.07.2022 11:06
Напишите программу результат которой будет: Привет, мой дорогой друг!Привет! решить задачу: a=b*5Хорошо, введи значение b:6 ответ=30(на языке python) очень...
sanik98
29.08.2021 06:11
написать код решения примера...
miloserdova2404
20.04.2021 17:29
Длинное целое Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input.txt Вывод стандартный вывод или output.txt Напишите программу, которая разные...
ангелина618
27.07.2022 15:34
Заполните таблицу которая на фото за лучший ответ 100 Предмет: Информатика на английском не спамте и не пишите всякую фигню дабы получить очень...
дима2855
14.06.2021 10:36
Найдите минимальное четырехзначное (в десятичной системе счисления) число, записи которого в троичной и семеричной системах счисления являются палиндромами....
dudka283847
24.05.2020 23:18
Для произвольного целого числа N 7 найти все такие пары целых чисел х и у, 3х + 5y = N,...
УльянаТонких
24.11.2021 06:42
Перевести число 390 из десятичной системы счисления в восьмеричную...
опчарготь
26.06.2022 09:16
Решить примеры алгебра-логики...
Санжик707
04.04.2023 16:38
Посмотреть на таблицу и ответить: Сколько байтов в 40000 Мб (с математическим действием)...
Ответ:
ксю882
30.12.2021 01:53
//Dev-C++ 4.9.9.2
//а
#include <iostream>
using namespace std;
const int n=10;
int main(){
int ar[n];
int arsub[n];
int m=0;
cout<<"Enter m:";
cin>>m;
cout<<"Enter array:"<<endl;
for(int i=0;i<n;i++)
cin>>ar[i];
for(int i=0;i<m;i++)
arsub[i]=ar[i];
for(int i=0;i<n-m;i++)
ar[i]=ar[i+m];
for(int i=0;i<m;i++)
ar[i+(n-m)]=arsub[i];
cout<<"Final array"<<endl;
for(int i=0;i<n;i++)
cout<<ar[i]<<' ';
cin.get();
cin.get();
return 0;
}
//б
#include <iostream>
using namespace std;
const int n=10;
int main(){
int ar[n];
int arsub[n];
int k,k1=0;
cout<<"Enter k:";
cin>>k;
cout<<"Enter array:"<<endl;
for(int i=0;i<n;i++)
cin>>ar[i];
for(int i=n-k;i<n;i++){
arsub[k1]=ar[i];k1++;}
for(int i=n;i>=k;i--)
ar[i]=ar[i-k];
for(int i=0;i<k;i++)
ar[i]=arsub[i];
cout<<"Final array"<<endl;
for(int i=0;i<n;i++)
cout<<ar[i]<<' ';
cin.get();
cin.get();
return 0;
}
0,0
(0 оценок)
Ответ:
vershynska
21.11.2021 06:21
#include <stdlib.h>
#include <iostream>
#include <iomanip>
using namespace std;
int main() {
const int n = 5;
double a[n][n];
double m1, m2;
srand(time(0));
for (int i = 0; i < n; i++){
for (int j = 0; j < n; j++){
a[i][j]=-20 + (101.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << setprecision (2) << a[i][j];
}
cout <<endl;
}
m1=a[0][0];
m2=a[0][n-1];
for (int i = 1; i < n; i++){
if (a[i][i]>m1) m1=a[i][i];
if (a[i][n-i-1]>m2) m2=a[i][n-i-1];
}
cout << "m1=" << m1 << " m2=" << m2 << endl;
}
37.11 71.19 25.77 53.53 35.74
39.90 63.69 11.67 70.38 -4.10
64.46 52.37 35.03 42.58 69.18
44.22 8.46 13.23 71.17 3.10
6.83 65.07 75.24 21.61 37.22
m1=71.17 m2=70.38
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота