lol1050
01.06.2023 08:49

составить программу по информатике на языке паскаль 8 класс

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
BaRiGaSimon
23.07.2022 19:15

Очень простой алгоритм:

 

Program Alexey;
{программа запрашивает у пользователя значения ежедневной температуры за 14 дней, и выводит максимальное и минимальное значения и в какие дни температруа достигала этих значений, а также вычисляет среднюю температуру за 2 недели}
uses crt;
const n=14;
var
  i, daymax, daymin:integer;
  t,max,min,sum:real;
begin
  writeln('Введите температуру за каждый день');
  write('День 1-й: T = ');
  readln(t);
  max:=t;
  min:=t;
  sum:=t;
  for i:=2 to 14 do //организуем цикл
    begin
      write('День ',i,'-й: T = ');
      readln(t);
      if t>max then
        begin
          max:=t; // найдено новое максимальное значение
          daymax:=i; // запоминаем соответствующий номер дня
        end;
      if t<min then
        begin
          min:=t; // найдено новое минимальное значение
          daymin:=i; // запоминаем соответствующий номер дня
        end;
      sum:=sum+t; //суммируем все значения t
    end;
  writeln();
  writeln('Максимальная температура была на ',daymax,'-й день: ',max,' градусов');
  writeln('Минимальная температура была на ',daymin,'-й день: ',min,' градусов');
  writeln('Средняя температура за 14 дней: ',sum/14,' градусов');
end.

0,0(0 оценок)
Ответ:
viteralinap06rap
09.05.2023 03:02

Program Tabulator;
uses GraphABC, crt;
var
  min,max,shag,x,y:real;
x0,y0,k,i,x1,y1:integer;
begin
  setWindowSize(640,640);
  x0:=300;
  y0:=300;
  k:=50;
  min:=2;
  max:=4;
  shag:=0.2;
  x:=min;
   line(x0,20,x0,600);   line(20,y0,620,y0);
   line(x0,20,x0-10,30);  line(x0,20,x0+10,30);
   line(630,y0,620,y0-10);  line(630,y0,620,y0+10);
   for i:=-5 to 5 do
       begin
       line(x0+(i*k),y0-10,x0+(i*k),y0+10);
       textout(x0+(i*k),y0+10,inttostr(i));
       end;
   for i:=-5 to 5 do
       begin
       line(x0-10,y0+(i*k),x0+10,y0+(i*k));
       if i<>0 then textout(x0+10,y0+(i*k),inttostr(-i));
       end;
  while x<=max do
    begin
     y:=0.1*x*x-x*cos(x);
     writeln(x:5:2,' ',y:5:2);
     x1:=trunc(x0+x*k);
     y1:=trunc(y0-y*k);
     setPenColor(clRed);
     circle(x1,y1,2);
     x:=x+shag;
    end;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота