21062017
24.11.2020 00:48

РЕШИТЬ В ПРОГРАММЕ ПАСКАЛЬ
1.На вход поступают положительные и отрицательные числа. Ввод
осуществляется до тех пор, пока не будет введен нуль. Найти сумму всех
введенных чисел с клавиатуры, а также количество неотрицательных чисел
(см. пример на слайде 4).
2. Напишите программу, которая в последовательности натуральных чисел
определяет сумму всех чисел, кратных 5. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Программа должна вывести одно число: сумму
всех чисел, кратных 5. (см. пример на слайде 8).
3.Напишите программу, которая в последовательности натуральных чисел
определяет количество всех чисел, оканчивающихся на 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно,
последовательность чисел заканчивается числом 0 (0 — признак окончания
ввода, не входит в последовательность). Программа должна вывести одно
число: количество всех чисел, оканчивающихся на 3. (см. пример на слайде РЕШИТЬ В ПРОГРАММЕ ПАСКАЛЬ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Maria21Kaplina2
01.04.2021 06:01

1)

var
    a, b, c, d, f : Integer;
   S : Real;
begin

 

   Writeln( 'Введите стороны треугольника:' );
   Write( 'a = ' ); Readlln( a );
   Write( 'b = ' ); Readlln( b );
   Write( 'c = ' ); Readlln( c );


   Writeln( 'Введите стороны прямоугольника:' );
   Write( 'd = ' ); Readlln( d );
   Write( 'f = ' ); Readlln( f );

   S := (a + b + c) / 2;
   S := sqr( S * (S-a) * (S-b) * (S-c) );

   if (d * f) = S then
      Writeln( 'S прямоугольника = S треугольника.' )
   else if (d * f) > S then
      Writeln( 'S прямоугольника больше.' )
   else
      Writeln( 'S треугольника больше.' );

   Readln;
end.

 

2)

var
   m, V, m1, V1 : Integer;
begin

   Writeln( 'Введите объем и массу первого тела:' );
   Write( 'm = ' ); Readlln( m );
   Write( 'V = ' ); Readlln( V );


   Writeln( 'Введите объем и массу второго тела:' );
   Write( 'm = ' ); Readlln( m1 );
   Write( 'V = ' ); Readlln( V1 );

   if (m / V) = (m1 / V1) then
      Writeln( 'Плотности равны.' )
   else if (m / V) > (m / V) then
      Writeln( 'Плотность первого тела больше.' )
   else
      Writeln( 'Плотность второго тела больше.' );

   Readln;
end.

 

3)

var
    a, b : Integer;
begin

 

   Writeln( 'Введите числа:' );
   Write( 'a = ' ); Readlln( a );
   Write( 'b = ' ); Readlln( b );


   if a mod b = 0 then
      Write( 'Число a является делителем числа b.' );

   if b mod a = 0 then
      Write( 'Число b является делителем числа a.' );

   Readln;
end.

0,0(0 оценок)
Ответ:
роман509
16.04.2020 18:57

Не совсем чётко сформулировано задание. Но попробую хоть в чём-то хотя можно ответить только на вопрос  типа "Сравнить размеры этих файлов".

 

Во втором файле по сравнению с первым

стерео *2

16 бит *2

48000  *6    (после * указываю во сколько раз больше, чем в 1 случае)

Таким образом, объём второго файла будет в 2*2*6=24раза больше, чем первого.

Ну где-то так...

 

Да, примерный объём первого файла за 10сек оценивается просто

10*1*8000=80 000 байт = 78Кбайт

Ну а второго

80000*24=1920000байт = 1875Кб=1.8М

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота