смурфик15
27.11.2022 03:29

N1 Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел,
кратных 8 и оканчивающихся на 2. Программа получает на вход количество чисел в
последовательности, а затем сами числа.

N2 Напишите программу, которая в последовательности натуральных чисел определяет Количество
чисел, кратных 8 и оканчивающихся на 2. Программа получает на вход количество чисел в
последовательности, а затем сами числа.
ПАСКАЛЬ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AnzhelaBagdasaryan
20.04.2023 23:20

1) 2,25 Мбайт, 2) 64 Мбайт, 3) 112,5 Мбайт

Объяснение:

1) K=1024*768 - количество пикселей

N=16777216 - количество цветов палитре

Решение N=2^i

I=K*i

16777216=2^24=2^i. Значит i=24 бита

I=1024*768*24/(8*1024)=2304 Кбайт=2,25 Мбайт

2) Дано:

N = 16 777 216

К = 1600 х 1200

Надо найти I

Решение:  N=2^i

I=K*i

16777216=2^24=2^i. Значит i=24 бита

I = 1600 · 1200 · 24 = 46 080 000 бит

46 080 000 бит = 5 760 000 байт = 5625 Кб = 5,5 Мб

Значит подойдет видеокарта лишь с 64 Мбайт.

3) Дано:

i = 16 битов

К = 1024 х 768

Частота обновления экрана = 75 Гц

Надо найти I

I = K · i

I = 1024 · 768 · 16 = 12 582 912 бит

12 582 912 бит = 1 572 864 байт = 1536 Кб = 1,5 Мб

Частота обновления означает, что за 1 с обновится 75 раз.

1,5 · 75 = 112,5 Мб

0,0(0 оценок)
Ответ:
Asuna2001
15.12.2020 04:29

program z1;

var a:integer;

begin

write('Введите шестизначное число: ');

readln(a);

if a div 1000 div 100 + a div 1000 mod 100 div 10 + a div 1000 mod 10 = a mod 1000 div 100 + a mod 1000 div 10 mod 10 + a mod 1000 mod 10

then write ('счастливый билет')

else write ('обычный билет')

end.

Объяснение:

Вводим число

Если сумма первых 3 цифр равна сумме последних 3 цифр, то билет счастливый, иначе обычный

a div 1000 - первые 3 цифры

a div 1000 div 100 - первая цифра первых 3 цифр

a div 1000 mod 100 div 10 - вторая цифра первых 3 цифр

a div 1000 mod 10  - третья цифра первых 3 цифр

a mod 1000 - последние 3 цифры

a mod 1000 div 100 - первая цифра последних 3 цифр

a mod 1000 div 10 mod 10 - вторая цифра последних 3 цифр

a mod 1000 mod 10  - третья цифра последних 3 цифр

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота