12345678йцуке
18.02.2023 10:11

написать программу
Напишите программу, которая определяет величину самой большой зарплаты
сотрудников и выводит количество сотрудников с этой максимальной зарплатой.
Формат входных данных:
В первой строке входного файла записано число N, о второй строке – через пробел N
чисел, обозначающих зарплату сотрудников в рублях (зарплата сотрудника не больше
105 рублей)
Формат выходных данных:
В выходном файле должно находиться одно число - количество сотрудников с
максимальной зарплатой.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Delishte
20.08.2022 18:24

Объяснение:

const

 max_elements = 1000;

 a = 1;

 b = 15;

 first_file_name = '1.txt';

 second_file_name = '2.txt';

var

 i, j, n, r:integer;

 p:real;

 ar:array[1..max_elements] of integer;

 f1, f2:text;

begin

 randomize;

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   ar[i]:=random(b-a+1)+a;

 end;

 assign(f1, first_file_name);

 rewrite(f1);

 for i:=1 to n do begin

   writeln(f1, ar[i]);

 end;

 close(f1);

 assign(f2, second_file_name);

 rewrite(f2);

 for i:=1 to n do begin

   p:=1;

   for j:=1 to i do

     p:=p*ar[j];

   writeln(f2, p:0:0);

 end;

 close(f2);

 readln;

end.

0,0(0 оценок)
Ответ:
sashaewr444
14.09.2020 04:14

Объяснение:

1.

var

 a:array[1..1000] of integer;

 i, n:integer;

 count:integer;

begin

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   writeln('Input a[', i, '] = ');

   readln(a[i]);

 end;

 count:=0;

 i:=1;

 while (i<=n) do begin

   if (((a[i] mod 3) = 0) and ((a[i] - (a[i] div 10)*10) = 2)) then count:=count + 1;

   i:=i+1;

 end;

 writeln(count);

 readln;

end.

2.

var

 a:array[1..1000] of integer;

 i, n:integer;

 count:integer;

begin

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   writeln('Input a[', i, '] = ');

   readln(a[i]);

 end;

 count:=0;

 i:=1;

 repeat

   if (((a[i] mod 3) = 0) and ((a[i] - (a[i] div 10)*10) = 2)) then count:=count + 1;

   i:=i+1;

 until (i > n);

 writeln(count);

 readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота