ледезе
25.09.2021 17:25

C++ Что надо написать вместо многоточия, чтобы вывести элементы массива X[N] в обратном порядке? В ответе не используйте пробелы.
for ( k=0; k cout << ... << endl;

Какой оператор надо вставить вместо многоточия, чтобы вывести на экран все элементы массива A[N] с четными номерами? В ответе не используйте пробелы.
k = 0;
while ( k < N ) {
cout << A[k] << " ";
...
}

Задан массив X[N]. Какой оператор надо поставить вместо многоточия, чтобы найти сумму всех элементов массива в переменной S? Вводите ответ без пробелов.
S = 0;
for ( k=0 k ...
}

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
анна3031
13.12.2022 06:31
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x

Программа:

var x, y, z: real;
begin
  writeln('Введите стороны треугольника x, y, z: ');
  read(x, y, z);
  if (x + y > z) and (x + z > y) and (y + z > x) 
  then writeln('Треугольник существует')
  else writeln('Треугольник не существует');
end.

2. Думаю, здесь излишни объяснения.

Программа:

var x, y, z: real;
begin
  writeln('Введите три числа: ');
  read(x, y, z);
  writeln('В интервале (1; 3) лежат числа: ');
  if (x > 1) and (x < 3) then writeln(x);
  if (y > 1) and (y < 3) then writeln(y);
  if (z > 1) and (z < 3) then writeln(z);
end.

Блок-схемы в приложении:
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
0,0(0 оценок)
Ответ:
victorastrakhan1
14.02.2023 23:44

Программа на PascalABC

Program 29844007;

uses  

 GraphABC;

var  

 XL1,YL1,XR1,YR1:integer;  ///координаты первого прямоугольника

 XL2,YL2,XR2,YR2:integer; ///координаты второго прямоугольника

 XL0,YL0,XR0,YR0:integer;  ///координаты результата

s:string; ///строка для вывода результатов;

begin

 Window.SetSize(700,700);  

 writeln('Первый прямоугольник: ');

   writeln('Введите X левого нижнего угла ');read(XL1);

   writeln('Введите Y левого нижнего угла ');read(YL1);

   writeln('Введите X правого верхнего угла ');read(XR1);

   writeln('Введите Y правого верхнего угла ');read(YR1);

 writeln('Второй прямоугольник: ');

   writeln('Введите X левого нижнего угла ');read(XL2);

   writeln('Введите Y левого нижнего угла ');read(YL2);

   writeln('Введите X правого верхнего угла ');read(XR2);

   writeln('Введите Y правого верхнего угла ');read(YR2);

 if XL1<XL2 then XL0:=XL1 else XL0:=XL2;

 if YL1<YL2 then YL0:=YL1 else YL0:=YL2;

 if XR1<XR2 then XR0:=XR2 else XR0:=XR1;

 if YR1<YR2 then YR0:=YR2 else YR0:=YR1;

/// Выводим сначала результирующий прямоугольник синим цветом

 Brush.Color := clBlue;

 Rectangle(XL0,700-YL0,XR0,700-YR0);

/// Рисуем первый прямоугольник красным цветом

 Brush.Color := clRed;

 Rectangle(XL1,700-YL1,XR1,700-YR1);

/// Выводим второй прямоугольник зелёным

 Brush.Color := clGreen;

 Rectangle(XL2,700-YL2,XR2,700-YR2);

/// Выводим кординаты

Brush.Color := clWhite;

 s:='Координаты левого нижнего угла: '+ IntToStr(XL0)+' '+IntToStr(YL0);

 TextOut(0,0,s);

 s:='Координаты правого верхнего угла: '+ IntToStr(XR0)+' '+IntToStr(YR0);

 TextOut(0,20,s);

end.

Пример вывода на прикреплённом рисунке.


Даны два прямоугольника, стороны которых параллельны или перпендикулярны осям координат. известны ко
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота