Tori1111111
05.06.2020 21:15

Составьте программу, которая позволяет удвоить каждый символ заданной строки.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
margaret1967m
27.01.2021 15:44

адрес ячейки в электронных таблицах состоит из имени столбца и следующего за ним номера строки, например, C15

·    формулы в электронных таблицах начинаются знаком = («равно»)

·    знаки +, –, *, / и ^ в формулах означают соответственно сложение, вычитание, умножение, деление и возведение в степень

·    запись B2:C4 означает диапазон, то есть, все ячейки внутри прямоугольника, ограниченного ячейками B2 и C4:

 например, по формуле =СУММ(B2:C4) вычисляется сумма значений ячеек B2, B3, B4, C2, C3 и C4

·    в заданиях ЕГЭ могут использоваться стандартные функции СЧЕТ (количество непустых ячеек), СУММ (сумма), СРЗНАЧ (среднее значение), МИН (минимальное значение),  МАКС (максимальное значение)

·    функция СРЗНАЧ при вычислении среднего арифметического не учитывает пустые ячейки и ячейки, заполненные текстом; например, после ввода формулы в C2 появится значение 2 (ячейка А2 – пустая):

Объяснение:

0,0(0 оценок)
Ответ:
kotikmotik55
30.06.2021 11:56
Задача 1

const N=30;
var a: array [1..N] of integer;
i,j,s: integer;
begin
for i:=1 to N do readln(a[i]);
for i:=1 to N do
if (a[i]>99)and(a[i]<1000) then
if (a[i] mod 2)<>0 then
begin
s:=s+a[i];
j:=j+1;
end;
if j=0 then writeln('в массиве нет нечётных трехзначных чисел')
else writeln('среднее арифметическое нечётных трехзначных чисел: ',s/j);
end.

задача 2

const N=40;
var a: array [1..N] of integer;
i,x,y: integer;
s: real;
begin
for i:=1 to N do readln(a[i]);
x:=abs(a[1]);
for i:=1 to N do
if (a[i]>0)and((a[i] mod x)=0) then
begin
y:=y+1;
s:=s+a[i];
end;
if y=0 then writeln('в массиве нет нечётных трехзначных чисел')
else writeln('среднее арифметическое положительных чисел кратных первому элементу: ',s/y);
end.

задача 3

const N=30;
var a: array [1..N] of integer;
i,s,m: integer;
begin
for i:=1 to N do readln(a[i]);
m:=a[1];
for i:=2 to N do
if a[i]>m then m:=a[i];
for i:=1 to N do
if a[i]=m then s:=s+1;
if s=1 then writeln('в массиве только один максимальный элемент')
else writeln('число элементов, равных максимальному: ',s-1);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота