никун
12.01.2022 16:27

Составить Блок - Схему, и написать программу.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yura23424
18.08.2021 09:58

Проверено на Паскаль АВС

Program TheStorm23;
uses crt;
var
  sum,n,i,r:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  sum:=0;
  writeln('Введите количество чисел, не превышающее 100');
  write('N = ');
  readln(n);
  if n>100 then
      writeln('Это слишком много!')
    else
      begin
        writeln('Вводите натуральные числа, не превышающие 300');
        for i:=1 to n do
          begin
            write('Ввод: ');
            readln (r);
            if r >300 then
                begin
                  writeln ('вы ввели слишком большое число');
                  writeln ('Это число не будет учтено');
                end
              else
                if r mod 6 = 0 then
                  sum:=sum+r;
          end;
        writeln();
        writeln('Сумма чисел, кратных 6, равна ',sum);
      end;
end.

0,0(0 оценок)
Ответ:
folaelena1
18.08.2021 09:58

--- Python 3.8.3 ---

def ReadSeq(SeqLen: int, SeqType = int):

   '''

   Возвращает последовательность элементов в указанном типе, считанных с клавиатуры, заданной длины.

   '''

   try:

       for _ in range(SeqLen):

           yield SeqType(input())

   except TypeError:

       raise RuntimeError(f'Unsupported type: {CastType}')

def main():

   n = int(input())

   Numbers = ReadSeq(n)

   print(sum(filter(lambda i: i % 6 == 0, Numbers)))

       

if __name__ == "__main__":

   main()

Программа эффективна по памяти, т.к в любой момент её работы с памяти храниться только один элемент последовательности

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота