Almira19681
21.07.2020 17:39

Функция для сортировки цифр по убыванию напишите программу ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
efimovap17
13.09.2022 19:59

class Person(object):

   def __init__(self, name = 'Bob', age = 25): #Значения по умолчанию заданы в конструкторе

       self._name = name  

       self._age = age  

   @property

   def name(self): #Свойство, возвращающее значение obj._name  

       return self._name

   

   @property

   def age(self):  #Свойство, возвращающее значение obj._age

       return self._age

   

   def say_hi(self): #Рандомный метод

       print(f'Hi, im {self._name}, im {self._age} yo')

   

   def set_age(self, value): #Метод для изменения значения свойства obj._age

       if value in range(1, 101):

           self._age = value

       else: raise RuntimeError('Bad Argument', f'Cant set age {value}, age must be in range [1, 100]')

Объяснение:

Второй класс попробуй реализовать сам

0,0(0 оценок)
Ответ:
Daniluha29
29.04.2021 08:19
#include <iostream>
#include <vector>
using namespace std;

int main() {
    unsigned short int n;
    cout << "n = ";
    cin >> n;
    vector<int> a;
    int in,
        avg,
        s = 0,
        c = 0;
    for (int i = 0; i < n; ++i) {
        cout << "a[" << i << "] = ";
        cin >> in;
        a.insert(a.end(), in);
        if (i % 2 == 1) {
            s += a.back();
            c++;
        }
    }
    avg = (int) s / c;
    cout << "Среднее арифметическое элементов на нечётных позициях: "
         << avg;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота