WaysWhite
16.04.2023 16:38

Больше дать не могу Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма Евклида. Программа должна подсчитать количество шагов цикла. Заполните таблицу: ответ двйте в виде двух целых чисел через запятую без лишних пробелов, Например: 123,2

a

358853

b

691042

НОД(a,b)

Шагов​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
guygoomy
01.12.2022 06:44

program HelloWorld;

var a: array of integer;

var N, min, max, i, variable:integer;

begin

   min := 32767;

   max := 0;

   readln(N);

   for i := 0 to N do begin  

       readln(variable);

       if (variable > 0) and (variable mod 2 = 0) and (variable > max) then

           max := variable;

       if (variable > 0) and (variable mod 2 = 0) and (variable < min) then

           min := variable;

   end;

   if (max <> 0) and (min <> 32767) then

       writeln(min, ' ', max)

   else  

       writeln(-1);

end.

0,0(0 оценок)
Ответ:
данаасус
04.12.2022 08:56

Ну сама считай)

Идут числа которые делятся на 3

3

6

9

12

15

18

21

24

И каждые 3 часа она делится на 2 т.е.

3=2 (изначально)

Потом 6=6 (т.к. 1 амеба делится на 2, получается что 2+2+2=6)

9=6 (сейчас 6 таких амёб поделились ещё на 2, т.е 18) и так далее

12= 18

15=54

18=162

21=486

24=1458

Т.е каждый раз просто плюсуешь три раза, потому что 1 амёба делится на 2 образуя 3 амёб, поэтому и плюсовать на одно и тоже число надо 3 раза

Если не поняла то смотри для примера возьму опять число 18:

18+18+18=54

Если решать долгим то сама всё поймешь:

(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)+(1+2)=54 (Можешь просто посчитать что тут 18 скобочек (1+2))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота