siyashka1
21.10.2022 11:23

1.Напишите программу на алгоритмическом языке,нарисуйте блох-схему и постройте трассировочную таблицу для следующего задания. Вывод чисел от 88 до 76.
2.Запишите условие,которое является истинным,когда 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Титанэжжжжж
29.08.2020 01:33
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
0,0(0 оценок)
Ответ:
verarusu02
06.05.2023 07:22
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота