михас3
10.05.2022 11:09

Приведите примеры программ с которых создали обычные модели​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Katyamaier777
18.11.2021 20:37

Web-страницы или гипертекстовые документы (html-документы) - это текстовые файлы, размеченные тегами (tags) с языка HTML (HyperText Markup Language). HTML не является языком программирования, он является языком разметки или средством форматирования гипертекста. Для разметки документа используются теги. Теги заключаются в угловые скобки. В основном теги являются парными, т.е. существуют открывающий и закрывающий теги.

Язык разметки HTML позволяет форматировать текст веб страницы, размещать на ней графические объекты, рисунки, вставлять звукозапись и различные мультимедийные элементы, а так же скрипты (JavaScript, VBScript), создавать гипертекстовые ссылки.

Веб-страница начинается и заканчивается парными тегами <html> и </html>. Между этими тегами размещаются парные теги <head>, </head> (голова веб-страницы), между которыми размещаются парные теги <title></title> для заголовка web-страницы, а также вводятся различные метатеги для ключевых слов, описания содержания страницы и т.д.

Затем следуют теги <body>, </body> (тело веб-страницы), между этими тегами размещается содержание или контент страницы.
Вот самый что не на есть стандартный шаблон страницы:
<html>
<head>
<!-- Тут подключаются различные стили, скрипты, а так же указывается краткая информация о странице в виде краткого описания и ключевых слов --> 
</head>
<body>
<!-- Тело страницы, тут располагается основной контент -->
</body>
</html>
Это всего лишь основа, на самом деле тегов в разметке очень много, например, есть еще теги <footer>, <sidebar>, <header> и т.д. Я даже не начал говорить о таких тегах как <div>, <ul> и т.п, много!
HTML - позволяет создавать только статичные страницы, т.е вся информация уже будет находиться на определенном .html-файле. Это конечно не плохо, если проект(сайт) будет не большим по размаху, но если он будет содержать 100-1000, а то и более страниц информации, то тут волей не волей уже задумаешься. Поскольку страницы статичные и если захотелось изменить дизайн сайта целиком, то придется редактировать КАЖДУЮ страницу! Это просто огромный, непосильный труд. Поэтому нам на идут языки веб-программирования такие, как PHP, Python и им подобные. Наиболее распространенный - это PHP(Personal HyperText Processor), распространен, потому что с ним легоко работать с БД(делать выборку, удалять, обновлять ну т.п). А в основном данные не статичных страниц хранятся в Базе Данных, это очень удобно и занимает меньше места. С языком ПХП можно просто создать один единый шаблон и просто использовать его, так не придется менять 1000 страниц, достаточно поменять одну единственную.
Это все кратко о создании Веб-страниц, не вдаваясь в детали. Надеюсь кратко и при этом понятно, удачи!:)

0,0(0 оценок)
Ответ:
ilyavladimirov1
27.09.2022 09:15
//PascalABC.NET
//Постройте алгоритм и составьте программу, по которой будет реализован
//следующий вариант сценарий: компьютер запрашивает номер дня недели,
//после ввода компьютер сообщает название этого дня (типо если ввели
//1 это понедельник 3 - среда)

type Arr = array [0..6] of string;

begin
    var DN: Arr := ('Воскресенье', 'Понедельник', 'Вторник', 'Среда',
                'Четверг', 'Пятница', 'Суббота');
    write('Введите порядковый номер дня недели: ');
    var n := ReadlnInteger;
    write('Этот день называется ', DN[n mod 7])
end.

Постройте алгоритм и составьте программу, по которой будет реализован следующий вариант сценарий: ко
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота