гуля5182
27.04.2022 13:15

Запустить программу Паскаль. Записать содержание программного кода n_6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
оопда
15.04.2021 12:38
Var
   Text,S:string;
   n,k:boolean;
   i:integer;
Begin
Write('Введите текст на русском языке: ');ReadLn(Text);
Text:=LowerCase(Text)+' '; // перевоит текст в нижний регистр
WriteLn(Text); // показывает действие предыдущей строки
For i:= 1 to Length(Text) do
    Begin
    if ('а' <= Text[i])and(Text[i] <= 'я')or(Text[i] = 'ё') then S:=S+Text[i] // записываем русские буквы в S
    else // как только встречаем другой символ, проверяем,
       if Length(S) > 0 then // есть ли в S хоть одна буква,
          Begin // и если есть, то проверяем условие задачки, и выводим слово на экран, если оно истинно
          if (S[1] in 'бвгджзйклмнпрстфхцчшщ')and(S[Length(S)] in 'аоэиуыеёюя') then WriteLn(S);
          S:=''; // далее обнуляем S
          End;
    End;
End.

Пример работы программы:

Введите текст на русском языке: Дан произвольный текст на русском языке. Написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
дан произвольный текст на русском языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
на
программу
которая
слова
начинающиеся
на
согласную
заканчивающиеся
0,0(0 оценок)
Ответ:
Меруерт999
16.04.2021 06:04
program summa;
var
sum:BigInteger;
i,n:integer;

begin
write ('n = ');
readln(n);  
sum:=0;    
i:=1;       
while i<= n do begin 
sum:=sum+i;         
i:=i+1;    
end;
writeln('Sum = ',sum);
end.


program krugi;
uses graphabc;
var
x,y,r:integer;

begin
setBrushColor(clGreen);  
x:=22; y:=22; r:=20;  
while x<660 do    begin     
circle(x,y,r);  
x:=x+40;        
end;
end.


program factorial;
var
pr:BigInteger;
i,n:integer;

begin
write ('n = ');
readln(n);  
pr:=1;    
i:=1;       
while i<= n do begin 
pr:=pr*i;         
i:=i+1;    
end;
writeln('Факториал числа n! = ',pr);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота