АндрейДемаков
30.09.2022 04:30

Сформировать массив целых чисел [-20...20]. Найти минимальный элемент и его номер. Написать программу в C++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

а. 17623,41683

b. 17908,47697

c. 18061,11235

d. 18166,96699

Объяснение:

 а) раз в год;    

  10000

1 год 10000 1200 11200

2 год 11200 1344 12544

3 год 12544 1505,28 14049,28

4 год 14049,28 1685,9136 15735,1936

5 год 15735,1936 1888,223232 17623,41683

   

b) раз в полгода;    

  10000

0,5 год 10000 600 10600

1 год 10600 636 11236

1,5 год 11236 674,16 11910,16

2 год 11910,16 714,6096 12624,7696

2,5 год 12624,7696 757,486176 13382,25578

3 год 13382,25578 802,9353466 14185,19112

3,5 год 14185,19112 851,1114674 15036,30259

4 год 15036,30259 902,1781554 15938,48075

4,5 год 15938,48075 956,3088447 16894,78959

5 год 16894,78959 1013,687375 17908,47697

   

c) раз в квартал;    

  10000

0,25 10000 300 10300

0,5 10300 309 10609

0,75 10609 318,27 10927,27

1 10927,27 327,8181 11255,0881

1,25 11255,0881 337,652643 11592,74074

1,5 11592,74074 347,7822223 11940,52297

1,75 11940,52297 358,215689 12298,73865

2 12298,73865 368,9621596 12667,70081

2,25 12667,70081 380,0310244 13047,73184

2,5 13047,73184 391,4319551 13439,16379

2,75 13439,16379 403,1749138 13842,33871

3 13842,33871 415,2701612 14257,60887

3,25 14257,60887 427,7282661 14685,33713

3,5 14685,33713 440,560114 15125,89725

3,75 15125,89725 453,7769175 15579,67417

4 15579,67417 467,390225 16047,06439

4,25 16047,06439 481,4119317 16528,47632

4,5 16528,47632 495,8542897 17024,33061

4,75 17024,33061 510,7299184 17535,06053

5 17535,06053 526,0518159 18061,11235

   

d) раз в месяц.    

  10000

1 месяц 10000 100 10100

2 месяц 10100 101 10201

3 месяц 10201 102,01 10303,01

4 месяц 10303,01 103,0301 10406,0401

5 месяц 10406,0401 104,060401 10510,1005

6 месяц 10510,1005 105,101005 10615,20151

7 месяц 10615,20151 106,1520151 10721,35352

8 месяц 10721,35352 107,2135352 10828,56706

9 месяц 10828,56706 108,2856706 10936,85273

10 месяц 10936,85273 109,3685273 11046,22125

11 месяц 11046,22125 110,4622125 11156,68347

12 месяц 11156,68347 111,5668347 11268,2503

13 месяц 11268,2503 112,682503 11380,9328

14 месяц 11380,9328 113,809328 11494,74213

15 месяц 11494,74213 114,9474213 11609,68955

16 месяц 11609,68955 116,0968955 11725,78645

17 месяц 11725,78645 117,2578645 11843,04431

18 месяц 11843,04431 118,4304431 11961,47476

19 месяц 11961,47476 119,6147476 12081,0895

20 месяц 12081,0895 120,810895 12201,9004

21 месяц 12201,9004 122,019004 12323,9194

22 месяц 12323,9194 123,239194 12447,1586

23 месяц 12447,1586 124,471586 12571,63018

24 месяц 12571,63018 125,7163018 12697,34649

25 месяц 12697,34649 126,9734649 12824,31995

26 месяц 12824,31995 128,2431995 12952,56315

27 месяц 12952,56315 129,5256315 13082,08878

28 месяц 13082,08878 130,8208878 13212,90967

29 месяц 13212,90967 132,1290967 13345,03877

30 месяц 13345,03877 133,4503877 13478,48915

31 месяц 13478,48915 134,7848915 13613,27404

32 месяц 13613,27404 136,1327404 13749,40679

33 месяц 13749,40679 137,4940679 13886,90085

34 месяц 13886,90085 138,8690085 14025,76986

35 месяц 14025,76986 140,2576986 14166,02756

36 месяц 14166,02756 141,6602756 14307,68784

37 месяц 14307,68784 143,0768784 14450,76471

38 месяц 14450,76471 144,5076471 14595,27236

39 месяц 14595,27236 145,9527236 14741,22509

40 месяц 14741,22509 147,4122509 14888,63734

41 месяц 14888,63734 148,8863734 15037,52371

42 месяц 15037,52371 150,3752371 15187,89895

43 месяц 15187,89895 151,8789895 15339,77794

44 месяц 15339,77794 153,3977794 15493,17572

45 месяц 15493,17572 154,9317572 15648,10747

46 месяц 15648,10747 156,4810747 15804,58855

47 месяц 15804,58855 158,0458855 15962,63443

48 месяц 15962,63443 159,6263443 16122,26078

49 месяц 16122,26078 161,2226078 16283,48338

50 месяц 16283,48338 162,8348338 16446,31822

51 месяц         16446,31822 164,4631822 16610,7814

52 месяц 16610,7814 166,107814 16776,88921

53 месяц 16776,88921 167,7688921 16944,65811

54 месяц 16944,65811 169,4465811 17114,10469

55 месяц 17114,10469 171,1410469 17285,24573

56 месяц 17285,24573 172,8524573 17458,09819

57 месяц 17458,09819 174,5809819 17632,67917

58 месяц 17632,67917 176,3267917 17809,00597

59 месяц 17809,00597 178,0900597 17987,09603

60 месяц 17987,09603 179,8709603 18166,96699

0,0(0 оценок)
Ответ:
Crownglas
24.01.2022 17:05

Некоторые изменения в коде на Питоне в отличие от Паскаля:

"const  n = 10;"  превратится в "n = 10"Присвоения обозначаются не :=, а просто =Раздел описаний нам не нужен, разве что можно сразу задать списки длины n: a = [None] * n; b = [None] * nВ Паскале некоторые переменные инициализируются нулем. Тут придется написать присвоение явно."for i := 1 to n do" превратится в "for i in range(1, n + 1):". Но так как нумерация элементов списка в Питоне начинается с нуля, имеет смысл поменять на range(n), чтобы действительно был проход по всем элементам. При этом в выводе придется поменять i на i + 1, чтобы сам вывод не поменялся.Вместо begin ... end используются отступыДля генерации случайных чисел в промежутке от 3 до 10 в модуле random есть функция randint, использование такое же, что и у random в исходной программеУсловная конструкция в Питоне if cond: ...Проверка на равенство ==, а не =Вывод - функция print. Чтобы Питон не добавлял лишние пробелы, нужно в функцию print дописать sep=''

Получается так:

Код (Python 3):

from random import randint

n = 10

a = [None] * n

b = [None] * n

maxs = 0

for i in range(n):

   a[i] = randint(3, 10)

   b[i] = randint(3, 10)

   if maxs < a[i] * b[i]:

       maxs = a[i] * b[i]

for i in range(n):

   if maxs == a[i] * b[i]:

       print(i + 1, ' Площадь=', a[i] * b[i] * 0.5, ' а=', a[i], ' b=', b[i], sep='')

Пример вывода:

5 Площадь=50.0 а=10 b=10

7 Площадь=50.0 а=10 b=10

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота