Niiiiklou
06.03.2021 00:31

Условие
Ваша задача — заполнить двумерный массив из N строк и N столбцов следующим образом: первая строка является упорядоченным набором чисел от 1 до N, каждая следующая является цикличным сдвигом влево предыдущей строки.

Формат входных данных
На первой и единственной строке входного файла дано одно целое число N (1≤N≤100).

Формат выходных данных
Выведите N строк по N столбцов — заполненный соответствующим образом двумерный массив очень кто нибудь

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
annaarzama
18.10.2020 00:11

1:

var i,n,a,s: integer;

begin

   s:=0;

   write('Введите количество чисел: '); readln(n);

   for i := 1 to n do begin

       write('Введите ', i,'-е число: '); readln(a);

       s:=s+a;

   end;

   write('Сумма введённых чисел равна: ', s);

end.

2:

var i,n,s: integer;

begin

   n:=50;

   s:=0;

   for i := 1 to n-1 do begin

       if i mod 2 = 0 then s:=s+i;

   end;

   write('Сумма положительных чётных чисел меньше ', n, ' равна: ', s);

end.

3.

var i,n: integer;

   s: real;

begin

   n := 20;

   s := 0;

   for i := 1 to n-1 do begin

       s := s + i / (n-1) ;

   end;

   write('Среднее арифметическое всех положительных чисел меньше ', n, ' равна: ', s:0:2);

end.

0,0(0 оценок)
Ответ:
nazmiburkanova7
22.02.2023 23:53

1: Opera

2: Opera Software

3: Персональные компьютера и телефоны на системах:  Microsoft Windows, macOS, Linux, Android и iOS

4: Встроенный VPN, блокировщик рекламы, удобный интерфейс, тонкая настройка, функция видео во всплывающем окне.

5: При отсутствии настройки от пользователя возможна сильная нагрузка на оперативную память.

6:Разработан в 1994 году группой исследователей из норвежской компании Telenor. С 1995 года — продукт компании Opera Software, образованной авторами первой версии браузера. Написан на языке C++

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота