eva444786
09.02.2021 03:31

1. Отметьте условия, записанные на языке Python правильно.
1) a ≥ 0
2) x <= 3
3) x > 0 or y < 0
4) c ≠ 0
5) a =! b
6) -5 < a < 10
7) x > 0, y < 0
8) a > 10 и b < 5
9) x== 6
10) x = y = z
11) x <> 0
2. Дана программа на языке Python:
print ('Введите три числа: ')
a, b, c = map (float, input(). split ())
x = a
if b < x:
x = b
if c < x:
x = c
print ('x=', x)
Что будет выведено в результате работы программы при следующих входных данных?
а) 10 5 1
б) 10 5 7
в) 2 10 5
Постройте блок-схему, соответствующую программе.
3. Напишите программу, которая производит обмен значений переменных x и y, если x больше у
Пример входных данных
x>>5
y>>6
Пример выходных данных
x= 5
y= 6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yuryklepikov
02.06.2022 07:59

program dimavdovuskin497;

type t1 = integer;

    t2 = double;

var n, i: t1;

   x, summa, pr: t2;

begin

writeln('Напишите программу, вычисляющую: а) сумму n первых натуральных четных чисел; б) произведение n первых натуральных нечетных чисел.');

writeln;

write('Введите общее количество чисел: ');

readln(n);

writeln;

summa := 0;

pr := 1;

for i := 1 to n do

begin

 write('Введите х: ');

 readln(x);

 writeln;

 if (frac(x) = 0) then

 begin

  if (frac(x/2) = 0) then summa := summa + x

   else pr := pr * x;

 end;

end;

writeln('Сумма n первых натуральных четных чисел равна ', summa : 5 : 0);

writeln;

writeln('Произведение n первых натуральных нечетных чисел равно', pr : 5 : 0);

readln;

end.

0,0(0 оценок)
Ответ:
shmitko85
06.02.2022 19:41

Правила организации личной информации в сети Интернет

старайтесь не заполнять анкеты данных в неизвестных чатах, социальных сетях,

не оставляйте встреченным в Интернете людям свой номер телефона, домашний адрес,

не отправляйте неизвестным людям свои фотографии,

общайтесь в программах Skype и им подобным только с друзьями,

не открывайте прикрепленные к письму файлы, полученные от незнакомых людей,

не разглашайте информацию о своем пароле

Правила безопасности в сети Интернет

не договаривайтесь о встрече с незнакомцами,

не отвечайте на недоброжелательные сообщения,

выходите из чата, если чье-то сообщение вызывает беспокойство,

будьте внимательны при загрузке бесплатных программ на компьютер,

если вы получили оскорбляющее сообщение, сообщение о нем родителям,

не поддавайтесь на заманчивые предложения,

не посещайте сайты для взрослых

Правила сетевого этикета

старайтесь выглядеть достойно в глазах собеседников,

пишите грамотно,

человек, с которым вы общаетесь, может быть не один,

сдерживайте страсти,

будьте терпимы к недостаткам окружающих

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота