polinaleskevic
06.11.2021 14:21

Написать программу задачи.
Задача.
По задать длины сторон треугольника, проверить является ли треугольник равносторонним.помагите

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lizagileva2015
21.01.2021 03:51
Разветвляющимися называется такой алгоритм, в котором выбирается один из нескольких возможных вариантов вычислительного процесса. каждый подобный путь называет "ветвью алгоритма".

признаком разветвляющегося алгоритма является наличие операций проверки условия. различают два вида условий –  простые  и  составные.

простым условием (отношением)  называется выражение, составленное из двух арифметических выражений или двух текстовых величин (иначе их еще ), связанных одним из знаков:

< - меньше,

> - больше,

< = - меньше, или равно

> = - больше, или равно

< > - не равно

= - равно

например, простыми отношениями являются следующие:

x-y> 10; k< =sqr(c)+abs(a+b); 9< > 11; ‘мама’< > ‘папа’.

в примерах первые два отношения включают в себя переменные, поэтому о верности этих отношений можно судить только при подстановке некоторых значений:

если х=25, у=3, то отношение x-y> 10 будет  верным, т.к. 25-3> 10

если х=5, у=30, то отношение x-y> 10 будет неверным, т.к. 5-30< 10

проверьте верность второго отношения при подстановке следующих значений:

а) k=5, a=1, b=-3, c=-8

b) k=65, a=10, b=-3, c=2

0,0(0 оценок)
Ответ:
Алёнка7913
21.03.2020 05:08
4 а)
const n=10;
var a:array[1..n] of integer; i,k:integer;
begin
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((i mod 2) = 0) then
a[i]:=a[i]*2
else
a[i]:=a[i]*3;
end;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
end.
б)
const n=10;
var a:array[1..n] of integer; i,k:integer;
begin
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((i mod 2) = 0) then
a[i]:=a[i]-a[i]*2;
end;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
end.
5 a)
const n=10;
var a:array[1..n] of integer; i,k:integer;
begin
k:=0;
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if (i>2) and (a[i]>a[i-1]) then
k:=k+1;
end;
writeln('Конечный массив: ');
for i:=1 to n do
 write(' ',a[i]);
writeln;
write('Кол-во элементов больших соседа слева ',k);
end.
5 б)
const n=10;
var a:array[1..n] of integer; z,i,k:integer;
begin
k:=0;
z:=0;
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((i mod 2) = 0) then
k:=k+1;
if k=2 then
 begin 
k:=0;
z:=z+1;
end;
end;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
writeln;
write('Кол-во четных пар: ',z);
end.
6 а)
const n=10;
var a:array[1..n] of integer; s,k,i:integer;
sr:real;
begin
s:=0;
k:=0;
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(10);
write(' ',a[i]);
end;
writeln;
for i:=1 to n do begin
if ((a[i] mod 2) = 0) and ((i mod 2) <> 0) then
begin
s:=s+a[i];
k:=k+1;
end;
end;
sr:=s/k;
writeln('Конечный массив: ');
for i:=1 to n do 
write(' ',a[i]);
writeln;
write('Среднее арифметическое четных элементов с нечетными индексами: ',sr);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота